
Дан квадратный массив. Поменяйте местами в каждом столбце элементы, стоящие на главной и побочной
диагонали. Входные данные В первой строке дано число n≤10. Далее идут n строк по n неотрицательных целых чисел не больше 100. Выходные данные Ответ на задачу. Примеры Ввод 3 1 2 3 4 5 6 7 8 9 Вывод 7 2 9 4 5 6 1 8 3 С++ Ваще без понятия как это делать

Ответы на вопрос

Ответ:
Объяснение:
#include <iostream>
#include <vector>
using namespace std;
int main()
{
int N;
cin >> N;
vector<vector<int>> a(N,vector<int> (N,0));
for (int i = 0; i < N; i++)
for (int j = 0; j < N; j++)
cin>> a[i][j];
for (int i = 0; i < N; i++)
swap(a[i][i], a[N - i - 1][i]);
cout << endl;
for (int i = 0; i < N; i++) {
for (int j = 0; j < N; j++)
cout << a[i][j] << " ";
cout << endl;
}
return 0;
}




Для решения этой задачи вам потребуется использовать двумерный массив (матрицу) и выполнить обмен элементов на главной и побочной диагонали. Ниже приведен C++ код, который решает данную задачу:
cpp#include <iostream>
using namespace std;
int main() {
int n;
cin >> n;
int matrix[10][10];
// Ввод матрицы
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
cin >> matrix[i][j];
}
}
// Обмен элементов на главной и побочной диагонали
for (int i = 0; i < n; i++) {
int temp = matrix[i][i]; // Запоминаем элемент на главной диагонали
matrix[i][i] = matrix[i][n - 1 - i]; // Заменяем элемент на главной диагонали на элемент на побочной диагонали
matrix[i][n - 1 - i] = temp; // Заменяем элемент на побочной диагонали на запомненный элемент
}
// Вывод измененной матрицы
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
cout << matrix[i][j] << " ";
}
cout << endl;
}
return 0;
}
Пример ввода и вывода для заданного вами примера:
Ввод:
3 1 2 3 4 5 6 7 8 9
Вывод:
7 2 9 4 5 6 1 8 3
Этот код сначала считывает размерность матрицы n
, затем вводит элементы матрицы. Затем он выполняет обмен элементов на главной и побочной диагонали и выводит измененную матрицу.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili