Вопрос задан 01.07.2023 в 09:55. Предмет Информатика. Спрашивает Касаткин Кирилл.

На вход программы подается текст на английском языке, заканчивающийся точкой (другие символы точка

в тексте отсутствуют). Требуется написать программу, которая будет определять и выводить на экран английскую букву(в верхнем регистре), встречающуюся в этом тексте чаще всего, и количество там таких букв. Строчные и прописные буквы при этом считаются не различимыми. Если искомых букв несколько, то программа должна выводить на экран первую из них по алфавиту. Входные данные На вход программы подается непустой текст на английском языке, заканчивающийся точкой (другие символы точка в тексте отсутствуют). Выходные данные Один символ - заглавная английская буква и через пробел число - количество таких букв в строке. Пример: Ввод It is not a simple task. Yes! Вывод I 3 Ввод AbbBB. Вывод B 4 Ввод Bb Aa Cc A. Вывод A 3 Желательно на Питоне или Паскале!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дьячков Дима.

Ответ:

def letter(text):

   text=text.split('.')

   text=text[0]

   text=text.split()

   text=''.join(text)

   text=text.upper()

   d={}

   for i in set(text):

       d[i]=text.count(i)

   maxim=max(d.values())

   s=0

   for k in d.values():

       if k==maxim:

           s+=1

   

   if s==1:

       for j in d:

           if d[j]==max(d.values()):

               return(f'{j} {d[j]}')

   else:

       qq={}

       for z in d:

           if d[z]==max(d.values()):

               qq[z]=max(d.values())

               

       for l in qq:        

           if l==min(qq.keys()):

               return(f'{l} {qq[l]}')

           

def runner():

   print(letter('It is not a simple task. Yes!'))

   print(letter('AbbBB'))

   print(letter('Bb Aa Cc A'))

runner()    

   

Объяснение:

Объяснение писать долго и неудобно) но если кому интересно, могу рассказать, например, через вк или дискорд. Напишите мне в личку

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример решения этой задачи на языке Python:

python
text = input("Введите текст: ").rstrip('.') # Ввод текста и удаление точки в конце text = text.upper() # Преобразование текста в верхний регистр # Создание словаря для подсчета количества букв letter_count = {} for letter in text: if letter.isalpha(): letter_count[letter] = letter_count.get(letter, 0) + 1 # Поиск буквы с наибольшим количеством повторений max_count = 0 max_letter = '' for letter, count in letter_count.items(): if count > max_count: max_count = count max_letter = letter elif count == max_count and letter < max_letter: # Если количество одинаково, выбираем первую по алфавиту max_letter = letter print(max_letter, max_count)

Это решение сначала принимает ввод от пользователя, затем удаляет точку в конце строки (если есть) и преобразует текст в верхний регистр. Затем оно создает словарь letter_count, где ключами являются буквы, а значениями - количество повторений каждой буквы в тексте.

Затем происходит поиск буквы с наибольшим количеством повторений в словаре letter_count. Если есть несколько букв с одинаковым максимальным количеством повторений, выбирается первая буква в алфавитном порядке.

Наконец, программа выводит найденную букву и количество повторений на экран.

Примеры использования:

less
Введите текст: It is not a simple task. Yes! I 3 Введите текст: AbbBB. B 4 Введите текст: Bb Aa Cc A. A 3

Надеюсь, это поможет вам решить задачу!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос