Вопрос задан 29.06.2023 в 10:03.
Предмет Информатика.
Спрашивает Глебова Наталия.
Напишите программу, которая считает сумму элементов массива целых чисел. Сначала задается целое
число N = размер массива (он всегда меньше или равен 10), затем N целых чисел, каждая на отдельной строке. Ввод вывод (readln, writeln). Вывести сумму. Пример ввод 3 1 2 3 Вывод 6Ответы на вопрос
Отвечает Никифоров Юрий.
Предоставлю 2 программы
1)var a: array [1..10] of integer;
i,n,s: integer;
begin
read(n);
for i:=1 to n do readln(a[i]);
for i:=1 to n do s:=s+a[i];
write(s);
end.
2)var a: array [1..10] of integer;
i,n,s: integer;
begin
read(n);
for i:=1 to n do begin readln(a[i]); s:=s+a[i]; end;
write(s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Pascal, которая считает сумму элементов массива целых чисел:
pascalprogram SumOfArrayElements; var N, i, sum: integer; arr: array[1..10] of integer; begin // Чтение размера массива readln(N); // Заполнение массива и вычисление суммы sum := 0; for i := 1 to N do begin readln(arr[i]); sum := sum + arr[i]; end; // Вывод суммы writeln(sum); end.
Вы можете вставить этот код в свою среду разработки Pascal и запустить программу, введя необходимые значения. Например, вводите "3", а затем "1", "2" и "3", как в вашем примере, и программа выведет сумму "6".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 25
Информатика 45
Информатика 13
Информатика 62
Информатика 21
Информатика 116
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
