Вопрос задан 28.06.2023 в 21:27. Предмет Информатика. Спрашивает Теребей Кирилл.

Составьте программу которая считает сумму чётных чисел которые не оканчиваются на 0​

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ракова Альбина.

N = int(input("Сколько чисел в последовательности? "))

s = 0

for i in range(N):

   x = int(input())

   if x % 10 != 0 and x % 2 == 0:

       s += x

print("Сумма =",s)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Python, которая вычисляет сумму чётных чисел, не оканчивающихся на 0 в заданном диапазоне:

python
def sum_of_even_numbers_not_ending_with_zero(start, end): total_sum = 0 for number in range(start, end + 1): if number % 2 == 0 and number % 10 != 0: total_sum += number return total_sum # Введите начало и конец диапазона для вычисления суммы start = int(input("Введите начало диапазона: ")) end = int(input("Введите конец диапазона: ")) result = sum_of_even_numbers_not_ending_with_zero(start, end) print(f"Сумма чётных чисел, не оканчивающихся на 0, в диапазоне от {start} до {end}: {result}")

Вы можете ввести начало и конец диапазона, и программа вычислит сумму чётных чисел, не оканчивающихся на 0, в этом диапазоне.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос