Вопрос задан 26.06.2023 в 19:45. Предмет Информатика. Спрашивает Панова Алёна.

РЕШИТЬ PYTHON 3 ПЖ Напишите программу, которая считывает последовательность из 10 целых чисел и

определяет является ли каждое из них четным или нет.Формат входных данныхНа вход программе подаются 10 целых чисел, каждое на отдельной строке.Формат выходных данныхПрограмма должна вывести строку «YES», если все числа четные и «NO» в ином случае.Sample Input 1:2468101214161820Sample Output 1:YESSample Input 2:12345678910Sample Output 2:NOРЕШИТЕ ПЖ ОЧЕНЬ НАДО ПОЖАЛУЙСТА ОЧЕНЬ А ТО МНЕ КАПЕЦ ОТ РОДОКОВ
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Головёнкин Андрей.

Ответ:

result = 'YES'

for i in range (0,10):

 if (int(input()))%2 != 0: result = 'NO'

print(result)

Или можно ещё так, чтобы ошибки входных данных отлавливать:

i = 0

result = 'YES'

while i<10:

 try:

   if (int(input()))%2 != 0: result = 'NO'

   i+=1

 except ValueError:

   print('Неверный формат входных данных. Вводите целое число.')

print(result)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам с этой задачей. Вот решение на Python:

python
# Считываем 10 чисел и проверяем их на четность even = True for _ in range(10): number = int(input()) if number % 2 != 0: even = False break # Выводим результат if even: print("YES") else: print("NO")

Вы можете вставить этот код в свою среду разработки или выполнить его в интерактивной среде Python. Затем введите 10 чисел по одному на каждой строке, как указано в условии, и программа выдаст соответствующий ответ.

Например, если вы введете:

2 4 6 8 10 12 14 16 18 20

Программа выведет:

objectivec
YES

А если введете:

1 2 3 4 5 6 7 8 9 10

Программа выведет:

objectivec
NO
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос