
Вопрос задан 25.06.2023 в 20:49.
Предмет Информатика.
Спрашивает Гусев Дмитрий.
Очень надо(тоько в паскале) Только в паскале при посещении бассейна существует скидка 10% скидка
от стоимости за посещение в утренние часы (с 7 до 12), а также за вечерние часы (20-23) в будние дни. напишите программу, которая получает время посещения и выводит соответствующее сообщение «скидка» или «скидка отсутствует». пример:введите время посещения:8скидка.пример:введите время посещения :15скидка отсутствует.

Ответы на вопрос

Отвечает Схождение Развал.
var
time : integer;
begin
write('Введите время посещения: ');
readln(time);
if ((time>=7) and(time<=12)) or ((time>=20) and (time<=23)) then
writeln('скидка')
else writeln('скидка отсутствует');
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Pascal, которая проверяет время посещения бассейна и выводит соответствующее сообщение:
pascalprogram DiscountChecker; var visitTime: integer; begin writeln('Введите время посещения: '); readln(visitTime); if ((visitTime >= 7) and (visitTime <= 12)) or ((visitTime >= 20) and (visitTime <= 23)) then writeln('Скидка') else writeln('Скидка отсутствует'); end.
Вы можете скопировать этот код в среду разработки Pascal и выполнить его, чтобы проверить, работает ли программа правильно для разных времен посещения бассейна.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili