
В ПАСКАЛЕ И ТОЛЬКО В ПАСКАЛЕ.1)дан массив десяти целых чисел напишите программу которая выводит
элементы массива в порядке не убывания.2)дан массив десяти целых чисел напишите программу которая выводит элементы массива в порядке убывания , а также выводит количество перестановок.3)дан массив десяти целых чисел. Найти медиану числового ряда.4) Дан массив десяти целых чисел выведите минимальное число массива оканчиговающегося на 45) дан массив десяти целых чисел напишите программу которая выводит на экран на экран максимальное число кратное 5.

Ответы на вопрос

var i,n,k:integer;
a:array[1..10] of integer;
begin
for i:=1 to 10 do
read(a[i]);
writeln;
for i:=10 downto 1 do
write(a[i],' ');
readln;
readln
end.
3)
var i,n,k:integer;
a:array[1..10] of integer;
begin
for i:=1 to 10 do
read(a[i]);
writeln;
writeln((a[5]+a[6])/2:0:2);
readln;
readln
end.
4)
var i,n,k,min:integer;
a:array[1..10] of integer;
begin
for i:=1 to 10 do
begin
read(a[i]);
if (a[i] mod 10=4) or (a[i] mod 10=-4)
then min:=a[i];
for i:=1 to 10 do
if ((a[i] mod 10=4) or (a[i] mod 10=-4)) and (a[i]<min)
then min:=a[i];
writeln(min);
end.
5)
var i,n,k,max:integer;
a:array[1..10] of integer;
begin
max:=0;
for i:=1 to 10 do
begin
read(a[i]);
if (a[i] mod 5=0) and (a[i]>max)
then max:=a[i];
end;
writeln(max);
end.



1) Вывод элементов массива в порядке неубывания
Для решения этой задачи нужно отсортировать элементы массива в порядке неубывания и вывести их на экран. В языке Pascal для сортировки массива можно использовать алгоритм сортировки пузырьком или встроенную функцию `Sort`.
Вот пример программы, которая решает эту задачу:
```pascal program SortArrayAscending; var arr: array[1..10] of integer; i, j, temp: integer; begin // Ввод элементов массива for i := 1 to 10 do begin write('Введите элемент массива arr[', i, ']: '); readln(arr[i]); end;
// Сортировка массива for i := 1 to 9 do begin for j := 1 to 10 - i do begin if arr[j] > arr[j + 1] then begin temp := arr[j]; arr[j] := arr[j + 1]; arr[j + 1] := temp; end; end; end;
// Вывод отсортированного массива writeln('Элементы массива в порядке неубывания:'); for i := 1 to 10 do begin write(arr[i], ' '); end; writeln; end. ```
2) Вывод элементов массива в порядке убывания и подсчет количества перестановок
Для решения этой задачи нужно отсортировать элементы массива в порядке убывания и вывести их на экран. Также нужно посчитать количество перестановок, которые были сделаны во время сортировки. В языке Pascal для сортировки массива можно использовать алгоритм сортировки пузырьком или встроенную функцию `Sort`.
Вот пример программы, которая решает эту задачу:
```pascal program SortArrayDescending; var arr: array[1..10] of integer; i, j, temp, swaps: integer; begin // Ввод элементов массива for i := 1 to 10 do begin write('Введите элемент массива arr[', i, ']: '); readln(arr[i]); end;
// Сортировка массива swaps := 0; for i := 1 to 9 do begin for j := 1 to 10 - i do begin if arr[j] < arr[j + 1] then begin temp := arr[j]; arr[j] := arr[j + 1]; arr[j + 1] := temp; swaps := swaps + 1; end; end; end;
// Вывод отсортированного массива writeln('Элементы массива в порядке убывания:'); for i := 1 to 10 do begin write(arr[i], ' '); end; writeln;
// Вывод количества перестановок writeln('Количество перестановок:', swaps); end. ```
3) Нахождение медианы числового ряда
Для нахождения медианы числового ряда нужно отсортировать массив чисел в порядке неубывания и найти середину ряда. Если количество элементов в ряду нечетное, то медианой будет средний элемент. Если количество элементов четное, то медианой будет среднее арифметическое двух средних элементов.
Вот пример программы, которая решает эту задачу:
```pascal program FindMedian; var arr: array[1..10] of integer; i, median: integer; begin // Ввод элементов массива for i := 1 to 10 do begin write('Введите элемент массива arr[', i, ']: '); readln(arr[i]); end;
// Сортировка массива for i := 1 to 9 do begin for j := 1 to 10 - i do begin if arr[j] > arr[j + 1] then begin temp := arr[j]; arr[j] := arr[j + 1]; arr[j + 1] := temp; end; end; end;
// Нахождение медианы if (10 mod 2) = 1 then begin median := arr[6]; end else begin median := (arr[5] + arr[6]) / 2; end;
// Вывод медианы writeln('Медиана числового ряда:', median); end. ```
4) Вывод минимального числа массива, оканчивающегося на 4
Для решения этой задачи нужно найти минимальное число в массиве, которое оканчивается на 4. Для этого нужно пройти по всем элементам массива и проверить, оканчивается ли текущий элемент на 4. Если элемент оканчивается на 4 и меньше текущего минимального числа, то обновить минимальное число.
Вот пример программы, которая решает эту задачу:
```pascal program FindMinEndingWith4; var arr: array[1..10] of integer; i, min: integer; begin // Ввод элементов массива for i := 1 to 10 do begin write('Введите элемент массива arr[', i, ']: '); readln(arr[i]); end;
// Нахождение минимального числа, оканчивающегося на 4 min := 1000000; // Задаем начальное значение минимального числа, которое гарантированно больше любого элемента массива for i := 1 to 10 do begin if (arr[i] mod 10) = 4 then begin if arr[i] < min then begin min := arr[i]; end; end; end;
// Вывод минимального числа, оканчивающегося на 4 writeln('Минимальное число массива, оканчивающееся на 4:', min); end. ```
5) Вывод максимального числа массива, кратного 5
Для решения этой задачи нужно найти максимальное число в массиве, которое является кратным 5. Для этого нужно пройти по всем элементам массива и проверить, делится ли текущий элемент на 5 без остатка. Если элемент делится на 5 и больше текущего максимального числа, то обновить максимальное число.
Вот пример программы, которая решает эту задачу:
```pascal program FindMaxMultipleOf5; var arr: array[1..10] of integer; i, max: integer; begin // Ввод элементов массива for i := 1 to 10 do begin write('Введите элемент массива arr[', i, ']: '); readln(arr[i]); end;
// Нахождение максимального числа, кратного 5 max := -1; // Задаем начальное значение максимального числа, которое гарантированно меньше любого элемента массива for i := 1 to 10 do begin if (arr[i] mod 5) = 0 then begin if arr[i] > max then begin max := arr[i]; end; end; end;
// Вывод максимального числа, кратного 5 writeln('Максимальное число массива, кратное 5:', max); end. ```
Надеюсь, эти примеры помогут вам решить поставленные задачи в языке Pascal. Если у вас возник


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili