Вопрос задан 23.06.2023 в 18:38. Предмет Информатика. Спрашивает Тихонова Даша.

Срочно! напишите программу на языке паскаль, чтобы там получался светофор (не мигающий, но цветной)​

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гараева Дарья.

Ответ:

// PascalABC.NET 3.1, сборка 1198 от 11.03.2016

uses GraphABC;

begin

 SetFontColor(clRed);

 SetFontSize(16);

 TextOut(50,50,'Красный свет - дороги нет!');

 Pen.Width:=3;

 DrawRectangle(140,100,240,300);

 Pen.Width:=1;

 Brush.Color:=clRed;

 Circle(190,150,20);

 Brush.Color:=clYellow;

 Circle(190,200,20);

 Brush.Color:=clLightGreen;

 Circle(190,250,20);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Pascal для создания светофора:

pascal
program TrafficLight; uses crt; const Red = 12; Yellow = 14; Green = 10; DelayTime = 1000; // Время задержки в миллисекундах procedure TurnOnLight(color: Integer); begin TextBackground(color); clrscr; delay(DelayTime); end; begin clrscr; writeln('Traffic Light Simulator'); while not keypressed do begin TurnOnLight(Red); TurnOnLight(Yellow); TurnOnLight(Green); end; end.

Эта программа использует модуль CRT для работы с консолью и определяет цвета для красного, желтого и зеленого светофорных сигналов. Затем она циклично отображает красный, желтый и зеленый светофорные сигналы с интервалами задержки, пока вы не нажмете клавишу на клавиатуре. Как только клавиша будет нажата, программа завершит выполнение.

Примечание: Этот код может работать только в среде, поддерживающей модуль CRT, такую как Turbo Pascal. Современные версии Pascal, такие как Free Pascal, могут не поддерживать этот модуль.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос