
Вопрос задан 23.06.2023 в 18:18.
Предмет Информатика.
Спрашивает Хлудеева Таня.
Помогите составить программу в Паскале!!! Дан массив, состоящий из 10 чисел, вводимых с
клавиатуры. Поменять минимальные и максимальные элементы местами.

Ответы на вопрос

Отвечает Тушнов Евгений.
Ответ:
int correct = 0;
for (int i = 0, i < #massiv; i++) {
correct++;
if (i > correct) {
continue;
}
else {
table.remove(i)
massiv[i] = i
}
}
вроде бы так



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль, которая позволяет поменять местами минимальный и максимальный элементы массива:
pascalprogram SwapMinMaxElements; var arr: array[1..10] of integer; i, minIdx, maxIdx, minValue, maxValue, temp: integer; begin writeln('Введите 10 чисел:'); for i := 1 to 10 do begin write('Введите элемент ', i, ': '); readln(arr[i]); end; minIdx := 1; maxIdx := 1; minValue := arr[1]; maxValue := arr[1]; for i := 2 to 10 do begin if arr[i] < minValue then begin minValue := arr[i]; minIdx := i; end else if arr[i] > maxValue then begin maxValue := arr[i]; maxIdx := i; end; end; writeln('Минимальный элемент: ', minValue); writeln('Максимальный элемент: ', maxValue); // Меняем местами минимальный и максимальный элементы temp := arr[minIdx]; arr[minIdx] := arr[maxIdx]; arr[maxIdx] := temp; writeln('Массив после замены минимального и максимального элементов:'); for i := 1 to 10 do write(arr[i], ' '); readln; end.
Эта программа позволяет вам ввести 10 чисел с клавиатуры, затем находит минимальный и максимальный элементы в массиве и меняет их местами.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili