Вопрос задан 17.06.2023 в 23:48. Предмет Информатика. Спрашивает Симонов Ярик.

Помогите сделать программу на wing101 обратный таймер от 20-ти до 0 секунд даю 65 балов

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Фарбей Настя.

С библиотекой time:

from time import sleep

for i in range(20, 0, -1):

   print(i, 'сек')

   sleep(1)

Без библиотеки:

for i in range(20, 0, -1):

   print(i, 'сек')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Python с использованием Wing 101 для создания обратного таймера от 20 до 0 секунд. Вот пример кода:

```python import time

def countdown(timer): while timer: mins, secs = divmod(timer, 60) timeformat = '{:02d}:{:02d}'.format(mins, secs) print(timeformat, end='\r') time.sleep(1) timer -= 1

print("Время вышло!")

# Установите начальное время обратного отсчета (в секундах) start_time = 20

countdown(start_time) ```

Как использовать этот код:

1. Откройте Wing 101. 2. Создайте новый файл и вставьте приведенный выше код. 3. Запустите программу, нажав F5 или выбрав "Run" в меню.

Этот код создает функцию `countdown`, которая принимает начальное время обратного отсчета в секундах и выводит таймер в формате "мм:сс". Программа затем входит в цикл, который уменьшает таймер каждую секунду, печатает оставшееся время и останавливается, когда таймер достигает 0.

Обратите внимание, что этот код будет работать в среде командной строки. Если вы хотите визуализировать таймер в графическом интерфейсе, вам придется использовать библиотеки, такие как Tkinter.

Помните, что программа будет блокировать выполнение кода на время таймера, поэтому если вам нужно выполнять другие задачи во время обратного отсчета, вам, возможно, придется использовать многозадачность или асинхронность.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос