Вопрос задан 22.08.2023 в 13:55.
Предмет Информатика.
Спрашивает Баттхёртов Мухаммед.
Пж помогите срочно !!!Напишите программу которая проверяет является ли введенное натуральное число
положительным кратным 7 ( на языке Паскаль ) даю 40 балловОтветы на вопрос
Отвечает Токальцев Даниил.
Program ch;
var a: integer;
begin
readln(a);
if(a mod 7=0) and (a>0) then writeln('yes');
else writeln('no');
end.
var a: integer;
begin
readln(a);
if(a mod 7=0) and (a>0) then writeln('yes');
else writeln('no');
end.
Отвечает Паюсов Алексей.
Var x:integer;
begin
read(x);
if(x<=0)then write('Не положительное')
else if(x mod 7 <>0)then write('Не кратно 7')
else write('Положительное и кратно 7');
end.
begin
read(x);
if(x<=0)then write('Не положительное')
else if(x mod 7 <>0)then write('Не кратно 7')
else write('Положительное и кратно 7');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль, которая проверяет, является ли введенное число положительным кратным 7:
pascalprogram CheckMultipleOf7; var num: Integer; begin writeln('Введите натуральное число: '); readln(num); if (num > 0) and (num mod 7 = 0) then writeln('Число является положительным кратным 7.') else writeln('Число не является положительным кратным 7.'); end.
Скопируйте этот код в среду программирования на Паскале и запустите. Программа запросит вас ввести число и выдаст результат проверки.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
