Написать программу для определения сдачи ребёнка в магазине Андрей покупает 3 кг яблок по x и 0 5
кг печенье по цене Y рублей. у него купюра z. напечатать сдачу. Прошу, помогите пожалуйста!!Ответы на вопрос
Відповідь:
#include <iostream>
using namespace std;
int main(){
setlocale(LC_ALL , "Rus");
int value;
float x,y,check,output;
cout << "Введите x цену яблок: ";
cin >> x;
cout << "Введите y цену печенья: ";
cin >> y;
cout << "Введите вашу купюру: ";
cin >> value;
if(value != 10 && value != 50 && value != 100 && value != 1000 && value != 2000 && value != 5000){
cout << "Такой купюры не существует" << endl;
}
else{
check = (3 * x) + (0.5 * y);
output = value - check;
cout << "Ваша сдача: " << output << endl;
}
return 0;
}
Пояснення:
Для решения этой задачи можно написать программу на языке Python. В программе мы будем использовать переменные для хранения значений веса яблок (apple_weight), цены яблок (apple_price), веса печенья (cookie_weight), цены печенья (cookie_price) и номинала купюры (bill_value).
Затем мы считаем общую стоимость покупки, умножая вес яблок на их цену и добавляя к этому произведению произведение веса печенья на его цену. Затем вычитаем из номинала купюры общую стоимость покупки и получаем сдачу.
Вот пример программы на языке Python, решающий данную задачу:
```python # Ввод данных apple_weight = float(input("Введите вес яблок (в кг): ")) apple_price = float(input("Введите цену яблок (за кг): ")) cookie_weight = float(input("Введите в
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
