Вопрос задан 16.06.2023 в 14:11. Предмет Информатика. Спрашивает Коц Генрих.

На Python! Составить программу, которая вычисляет оптимальный вес пользователя, сравнивает его с

реальным весом (его вводит пользователь), выдает рекомендацию о необходимости поправиться или похудеть на некоторое количество или сообщает о том, что пользователь в идеальной форме.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шмеркина Лизочка.

Ответ:

вижу это так

Объяснение:

x=int(input('Введите свой вес:'))

if x<50:

   print('Необходимо поправиться на', 80-x, 'кг')

elif x>=50 and x<80:

   print('Оптимальный вес')

else:

   print('Необходимо похудеть на',x-80, 'кг')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи на Python, можно написать программу, которая принимает ввод от пользователя о его реальном весе, вычисляет оптимальный вес и дает рекомендацию о необходимости поправиться или похудеть. Вот пример такой программы:

```python def calculate_optimal_weight(): real_weight = float(input("Введите ваш реальный вес (в кг): ")) height = float(input("Введите ваш рост (в метрах): ")) # Вычисляем оптимальный вес по формуле Индекса Массы Тела (ИМТ) optimal_weight = 22 * (height ** 2) if real_weight > optimal_weight: weight_difference = real_weight - optimal_weight print(f"Ваш реальный вес превышает оптимальный на {weight_difference} кг.") print("Рекомендуется похудеть на некоторое количество килограмм.") elif real_weight < optimal_weight: weight_difference = optimal_weight - real_weight print(f"Ваш реальный вес меньше оптимального на {weight_difference} кг.") print("Рекомендуется поправиться на некоторое количество килограмм.") else: print("Ваш вес находится в идеальной форме.")

calculate_optimal_weight() ```

В данной программе: 1. Функция `calculate_optimal_weight()` запрашивает у пользователя его реальный вес и рост. 2. Оптимальный вес вычисляется по формуле Индекса Массы Тела (ИМТ), где оптимальный ИМТ равен 22. 3. Сравнивается реальный вес с оптимальным весом. Если реальный вес больше оптимального, вычисляется разница и выводится рекомендация о необходимости похудеть. Если реальный вес меньше оптимального, вычисляется разница и выводится рекомендация о необходимости поправиться. Если реальный вес равен оптимальному, выводится сообщение о том, что пользователь находится в идеальной форме.

Надеюсь, данная программа поможет вам решить задачу! Если у вас есть дополнительные вопросы, не стесняйтесь задавать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос