 
Вопрос задан 30.04.2021 в 13:04.
Предмет Информатика.
Спрашивает Дятлов Дима.
Написать программу, которая запрашивает реальный рост и вес пользователя, вычисляет его оптимальный
вес, сравнивает его с реальным и выдает рекомендацию о необходимости поправиться или похудеть. Pascal ABC 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Хазиев Александр.
                
                   Var              
p,h,imt:real;
begin
Write('Введите вес в кг и рост в см: ');
Read(p,h);
imt:=p/Sqr(h/100);
if imt<=16 then Writeln('Дефицит массы тела. Необходимо поправиться.')
else if imt<25 then Writeln('Нормальный вес! Так держать!')
else if imt<=30 then Writeln('Избыточная масса тела. Нужно худеть.')
else if imt<=35 then Writeln('Ожирение 1-й степени. Необходимо похудеть.')
else if imt<=45 then Writeln('Ожирение 2-й степени. Срочно худейте!')
else Writeln('Ожирение 3-й степени. Немедленно начинайте худеть!!!')
end.
              
                                        p,h,imt:real;
begin
Write('Введите вес в кг и рост в см: ');
Read(p,h);
imt:=p/Sqr(h/100);
if imt<=16 then Writeln('Дефицит массы тела. Необходимо поправиться.')
else if imt<25 then Writeln('Нормальный вес! Так держать!')
else if imt<=30 then Writeln('Избыточная масса тела. Нужно худеть.')
else if imt<=35 then Writeln('Ожирение 1-й степени. Необходимо похудеть.')
else if imt<=45 then Writeln('Ожирение 2-й степени. Срочно худейте!')
else Writeln('Ожирение 3-й степени. Немедленно начинайте худеть!!!')
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Вот пример программы на Pascal ABC, которая запрашивает рост и вес пользователя, вычисляет его оптимальный вес и сравнивает его с реальным, выводит рекомендацию о необходимости поправиться или похудеть:
arduinoprogram OptimalWeight;
var
  height, weight, optimalWeight, difference: real;
begin
  write('Введите свой рост (в метрах): ');
  readln(height);
  write('Введите свой вес (в килограммах): ');
  readln(weight);
  
  optimalWeight := (height * 100 - 100) * 0.9;
  difference := weight - optimalWeight;
  
  writeln('Ваш оптимальный вес: ', optimalWeight:0:1, ' кг.');
  
  if difference = 0 then
    writeln('Ваш вес идеален!')
  else if difference > 0 then
    writeln('Вам нужно похудеть на ', difference:0:1, ' кг.')
  else
    writeln('Вам нужно поправиться на ', abs(difference):0:1, ' кг.');
  
  readln;
end.
Как работает программа:
- Сначала пользователь должен ввести свой рост и вес в метрах и килограммах соответственно.
- Затем программа вычисляет оптимальный вес, используя формулу: (рост в см - 100) * 0.9.
- Разница между реальным весом и оптимальным весом вычисляется и сохраняется в переменной "разница".
- Программа выводит оптимальный вес и рекомендацию в зависимости от разницы между реальным и оптимальным весом.
- Если разница равна 0, то выводится сообщение "Ваш вес идеален!"
- Если разница больше 0, то выводится сообщение "Вам нужно похудеть на [разница] кг."
- Если разница меньше 0, то выводится сообщение "Вам нужно поправиться на [абсолютное значение разницы] кг."
Надеюсь, это поможет!
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			