Задание 1. Составить программу, которая, если введенное число отрицательное, меняет его на
противоположное, если число положительное удвоить его, если число равно 0 - увеличить на 50 СРОЧНО НУЖНО ПОЖАЛУЙСТА даю 20 балов Ответы на вопрос
Ответ:
Друг, извини, первое условие не знаю как поставить, но зато сделал 2 других:
#include <iostream>
int setting()
{
int x;
std::cin >> x;
if (x > 0)
std::cout << x * 2 << std::endl;
if (x == 0)
std::cout << x + 50 << std::endl;;
return 0;
}
int main()
{
setting();
return 0;
}
Объяснение:
Для решения данной задачи можно написать программу на языке Python. Вот пример такой программы:
```python number = int(input("Введите число: "))
if number < 0: number = -number elif number > 0: number = number * 2 else: number = number + 50
print("Результат:", number) ```
В этой программе мы сначала запрашиваем у пользователя ввод числа с помощью функции `input()`. Затем мы проверяем условия: - Если число меньше нуля, мы меняем его знак на противоположный, используя оператор `-`. - Если число больше нуля, мы удваиваем его, используя оператор `*`. - Если число равно нулю, мы увеличиваем его на 50, используя оператор `+`.
Наконец, мы выводим результат с помощью функции `print()`.
Примечание: В данном случае, поскольку задача не требует обработки ошибок, мы предполагаем, что пользователь вводит только целые числа.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
