Вопрос задан 15.06.2023 в 12:30. Предмет Информатика. Спрашивает Громцева Ксения.

Напишите программу,которая получает с клавиатуры возраст ребёнка и выводит соответствующую

образовательную организацию
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Анисимов Иван.

Ответ:

Программа написана на языке программирования Python.Также прикрепил фото.

Объяснение:

while True:

try:

 age = input('Введите возвраст:\n(для выхода введите "стоп") ')

 if age.lower() == 'стоп':

  break

 else:

  age = int(age)

except ValueError:

 print('--- Пожалуйста,введите возраст от 1 года ---')

else:

 if age == 0 or age <0:

  print('--- Пожалуйста,введите возраст от 1 года ---')

 elif age <3:

  print('Ясли (дошкольная образовательная организация)')

 elif age < 7:

  print('Детский сад (дошкольная образовательная организация)')

 elif age < 16:

  print('Школа,гимназия,лицей (общеобразовательные организации)')

 elif age >= 16 and age < 18:

  print('Школа,гимназия,лицей (общеобразовательные организации),колледж(профессиональная образовательная организация)')

 else:

  print('Университет,академия,институт(высшие образовательные организации),колледж(профессиональная образовательная организация)')


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам с написанием программы, которая будет получать возраст ребенка с клавиатуры и выводить соответствующую образовательную организацию. Вот пример такой программы на языке Python:

```python def find_educational_organization(age): if age < 3: return "Дошкольное образование не требуется" elif age < 6: return "Детский сад" elif age < 18: return "Школа" elif age < 22: return "ВУЗ" else: return "Образование не требуется"

age = int(input("Введите возраст ребенка: ")) organization = find_educational_organization(age) print("Соответствующая образовательная организация:", organization) ```

В данной программе используется функция `find_educational_organization`, которая принимает возраст ребенка в качестве аргумента и возвращает соответствующую образовательную организацию. Затем программа запрашивает у пользователя возраст ребенка с клавиатуры, вызывает функцию `find_educational_organization` и выводит результат на экран.

Пример работы программы: ``` Введите возраст ребенка: 4 Соответствующая образовательная организация: Детский сад ```

Надеюсь, это поможет вам создать программу, которая будет выполнять требуемую функцию. Если у вас возникнут дополнительные вопросы или потребуется дальнейшая помощь, пожалуйста, сообщите мне.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос