Вопрос задан 14.06.2023 в 04:51. Предмет Информатика. Спрашивает Азин Тимур.

Код на C#. Напишите программу для нахождения максимального элемента в каждом столбце и минимального

в каждой строке квадратной матрицы.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Огнева Даша.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Threading.Tasks;

namespace AutoIT // это название проекта. Ты можешь назвать

                                 // по-другому

{

   internal class Program

   {

       static void Main(string[] args)

       {

           int N;

           N = int.Parse(Console.ReadLine());

         

           int[,] vs = new int[N, N];

           for(int i = 0; i < N; i++)

           {

               for (int j = 0; j < N; j++)

               {

                   vs[i, j] = int.Parse(Console.ReadLine());

               }

           }

           for(int i = 0; i < N; i++)

           {

               Console.WriteLine();

               for (int j = 0; j < N; j++)

               {

                   Console.Write(String.Format("{0,3}", vs[i, j]));

               }

               Console.WriteLine();

           }

           Console.WriteLine("Минимальные элементы в каждой строчке");

           for (int i = 0; i < N; i++)

           {

               int min = 10000;

               for (int j = 0; j < N; j++)

               {

                   if(min > vs[i,j]) min = vs[i,j];

               }

               Console.WriteLine(min);

           }

           Console.WriteLine("Максимальные элементы в каждом столбце");

           for (int j = 0; j < N; j++)

           {

               int max = -10000;

               for (int i = 0; i < N; i++)

               {

                   if (max < vs[i, j]) max = vs[i, j];

               }

               Console.WriteLine(max);

           }

           Console.ReadLine();

       }

   }

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на C#, которая находит максимальный элемент в каждом столбце и минимальный элемент в каждой строке квадратной матрицы:

csharp
using System; class Program { static void Main() { // Создаем квадратную матрицу int[,] matrix = { { 1, 2, 3 }, { 4, 5, 6 }, { 7, 8, 9 } }; int rows = matrix.GetLength(0); // Количество строк int columns = matrix.GetLength(1); // Количество столбцов // Находим максимальный элемент в каждом столбце for (int col = 0; col < columns; col++) { int maxElement = matrix[0, col]; for (int row = 1; row < rows; row++) { if (matrix[row, col] > maxElement) { maxElement = matrix[row, col]; } } Console.WriteLine("Максимальный элемент в столбце {0}: {1}", col, maxElement); } // Находим минимальный элемент в каждой строке for (int row = 0; row < rows; row++) { int minElement = matrix[row, 0]; for (int col = 1; col < columns; col++) { if (matrix[row, col] < minElement) { minElement = matrix[row, col]; } } Console.WriteLine("Минимальный элемент в строке {0}: {1}", row, minElement); } } }

Программа создает квадратную матрицу размером 3x3 и находит максимальный элемент в каждом столбце и минимальный элемент в каждой строке. Выводятся результаты в консоль.

Вы можете изменить размеры матрицы и ее элементы, внести свои данные вместо примера, чтобы адаптировать программу под вашу задачу.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос