Вопрос задан 29.04.2021 в 14:39.
Предмет Информатика.
Спрашивает Безрукова Ирина.
Составьте программу подсчёта числа различных отрицательных элементов одномерного массива A(Q)
ПаскальОтветы на вопрос
Отвечает Силянков Артём.
//PascalABC.NET 3.1 сборка 1239
begin
Println(ArrRandom(100, -50 ,50).Count(x->x<0));
end.
begin
Println(ArrRandom(100, -50 ,50).Count(x->x<0));
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Привет! Вот простая программа на языке Pascal для подсчета числа различных отрицательных элементов одномерного массива A(Q):
vbnetprogram NegativeElementsCount;
var
A: array of Integer;
Q, i, count: Integer;
negatives: set of Integer;
begin
write('Enter the size of the array: ');
readln(Q);
SetLength(A, Q);
write('Enter the elements of the array: ');
for i := 0 to Q - 1 do
begin
readln(A[i]);
if A[i] < 0 then
negatives := negatives + [A[i]];
end;
count := negatives.Count;
writeln('The number of different negative elements in the array is: ', count);
readln;
end.
В этой программе мы объявляем массив A типа Integer, а также переменные Q (размер массива), i (счетчик цикла), count (количество различных отрицательных элементов) и множество negatives для хранения уникальных отрицательных элементов.
После того, как пользователь вводит размер массива и элементы массива, мы проходим по каждому элементу и добавляем отрицательные элементы в множество negatives. Затем мы считаем количество элементов в множестве negatives и выводим его на экран.
Надеюсь, это поможет!
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 21
Информатика 29
Информатика 21
Информатика 20
Информатика 25
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
