Вопрос задан 02.04.2021 в 03:40.
Предмет Информатика.
Спрашивает Кротов Михаил.
40 баллов !!!Напишите программу, которая по порядковому номеру месяца выводит на экран время года
(через условный оператор if, и с объяснением пожалуйста )Ответы на вопрос
Отвечает Чижик Ярослав.
Тут есть несколько вариантов, как это можно записать:
Если номера месяцев не превысят 12, то есть имеются ввиду только месяцы одного года, то вот так:
Var
N:integer;
Begin
WriteLn('Введите номер месяца');
ReadLn(N);
if (N = 12)or(N = 1)or(N = 2) then WriteLn('Зима') //если N = 12, 1 или 2, то выводим 'Зима', иначе идём по следующей ветке if, проверяем следующее условие
else if (N = 3)or(N = 4)or(N = 5) then WriteLn('Весна') // тут точно также N = 3, 4 или 5, если нет - то проверяем следующее условие
else if (N = 6)or(N = 7)or(N = 8) then WriteLn('Лето')
else if (N = 9)or(N = 10)or(N = 11) then WriteLn('Осень')
End.
Если же номер месяца может превысить 12, то перед проверкой нужно найти остаток от деления этого числа на количество месяцев, то есть на 12. При этом остаток от деления 12 на 12 = 0.
Var
N:integer;
Begin
WriteLn('Введите номер месяца');
ReadLn(N);
N:= N mod 12;
if (N = 0)or(N = 1)or(N = 2) then WriteLn('Зима')
else if (N = 3)or(N = 4)or(N = 5) then WriteLn('Весна')
else if (N = 6)or(N = 7)or(N = 8) then WriteLn('Лето')
else if (N = 9)or(N = 10)or(N = 11) then WriteLn('Осень')
End.
Эти же самые условия можно записать иначе:
if (N>=0)and(N<=2) then
или:
if (N>=0)and(N<3) then
Если номера месяцев не превысят 12, то есть имеются ввиду только месяцы одного года, то вот так:
Var
N:integer;
Begin
WriteLn('Введите номер месяца');
ReadLn(N);
if (N = 12)or(N = 1)or(N = 2) then WriteLn('Зима') //если N = 12, 1 или 2, то выводим 'Зима', иначе идём по следующей ветке if, проверяем следующее условие
else if (N = 3)or(N = 4)or(N = 5) then WriteLn('Весна') // тут точно также N = 3, 4 или 5, если нет - то проверяем следующее условие
else if (N = 6)or(N = 7)or(N = 8) then WriteLn('Лето')
else if (N = 9)or(N = 10)or(N = 11) then WriteLn('Осень')
End.
Если же номер месяца может превысить 12, то перед проверкой нужно найти остаток от деления этого числа на количество месяцев, то есть на 12. При этом остаток от деления 12 на 12 = 0.
Var
N:integer;
Begin
WriteLn('Введите номер месяца');
ReadLn(N);
N:= N mod 12;
if (N = 0)or(N = 1)or(N = 2) then WriteLn('Зима')
else if (N = 3)or(N = 4)or(N = 5) then WriteLn('Весна')
else if (N = 6)or(N = 7)or(N = 8) then WriteLn('Лето')
else if (N = 9)or(N = 10)or(N = 11) then WriteLn('Осень')
End.
Эти же самые условия можно записать иначе:
if (N>=0)and(N<=2) then
или:
if (N>=0)and(N<3) then
Отвечает Мамонова Карина.
Var n:integer;
begin
write('n = ');
readln(n);
if n in [1,2,12] then writeln('Зима')
else if n in [3,4,5] then writeln('Весна')
else if n in [6,7,8] then writeln('Лето')
else if n in [9,10,11] then writeln('Осень')
else writeln('Ошибка ввода');
end.
Пример:
n = 3
Весна
begin
write('n = ');
readln(n);
if n in [1,2,12] then writeln('Зима')
else if n in [3,4,5] then writeln('Весна')
else if n in [6,7,8] then writeln('Лето')
else if n in [9,10,11] then writeln('Осень')
else writeln('Ошибка ввода');
end.
Пример:
n = 3
Весна
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на Python, которая по порядковому номеру месяца выводит соответствующее время года:
pythonmonth = int(input("Введите порядковый номер месяца: "))
if month == 12 or month == 1 or month == 2:
print("Зима")
elif month == 3 or month == 4 or month == 5:
print("Весна")
elif month == 6 or month == 7 or month == 8:
print("Лето")
elif month == 9 or month == 10 or month == 11:
print("Осень")
else:
print("Некорректный номер месяца")
В данной программе используется условный оператор if-elif-else. После ввода порядкового номера месяца пользователем, мы проверяем его значение и выводим соответствующее время года.
- Если значение
monthравно 12, 1 или 2, программа выводит "Зима". - Если значение
monthравно 3, 4 или 5, программа выводит "Весна". - Если значение
monthравно 6, 7 или 8, программа выводит "Лето". - Если значение
monthравно 9, 10 или 11, программа выводит "Осень". - Если значение
monthне соответствует ни одному из этих условий, программа выводит "Некорректный номер месяца".
Таким образом, программа определяет время года на основе порядкового номера месяца, введенного пользователем.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
