помогите написать программу которая вычисляет сумму положительных из n введенных с клавиатуры целых
чисел (FOR) В паскале ABCОтветы на вопрос
program z1; (Начало программы)
var n, s, i, c:integer; (Раздел описания переменных, n(кол-во чисел), s(сумма чисел), i(счетчик), с(число, введенное с клавиатуры))
begin (тело программы)
writeln ('Кол-во чисел?'); (подсказка для пользавателя)
readln (n); (считывание переменной)
s:=0; (обнуляем переменную)
For i:= 1 to n do begin (цикл будет повторяться от 1 до N; т.к в цикле будет несколько действий открываем операторные скобки (begin\end), начало цикла)
writeln ('Введите число'); (подсказка для пользавателя)
readln(c); (считывание переменной)
If c>0 then s:=s+c; (если с>0 тогда к сумме мы прибавляем число)
end; (конец цикла)
writeln ('Сумма=',s); (подсказка для пользавателя и ответ)
readln(s); (считывание переменной)
readln; (считывание)
end.(конец программы)
Конечно! Вот пример программы на языке Pascal ABC, которая вычисляет сумму положительных чисел из n введенных с клавиатуры:
pascalprogram SumPositiveNumbers; var n, number, sum: integer; i: integer; begin writeln('Введите количество чисел n:'); readln(n); sum := 0; writeln('Введите ', n, ' целых чисел:'); for i := 1 to n do begin readln(number); if number > 0 then sum := sum + number; end; writeln('Сумма положительных чисел:', sum); readln; end.
Программа запрашивает количество чисел n, а затем считывает n целых чисел с клавиатуры. После этого она вычисляет сумму положительных чисел и выводит результат на экран.
Надеюсь, это помогло! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
