Вопрос задан 13.02.2021 в 19:55. Предмет Информатика. Спрашивает Сорокина Даша.

. Постройте алгоритм и составьте программу, по которой будет реализован следующий сценарий:

компьютер запрашивает номер дня недели, после ввода компьютер сообщает название этого дня. Например, если ввели 1, то выведется фраза "Это понедельник" и т. д.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Загинайлов Артем.
Var i:integer;
begin
readln(i);
case i of
1: writeln('Понедельник');
2: writeln('Вторник');
3: writeln('Среда');
4: writeln('Четверг');
5: writeln('Пятница');
6: writeln('Суббота');
7: writeln('Воскресенье') 
else writeln('нет такого дня');
end;
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Привет! Я могу помочь тебе с написанием программы на Python, которая реализует данный сценарий. Вот пример алгоритма и программы:

  1. Запросить у пользователя номер дня недели.
  2. Используя условные операторы, сопоставить введенное значение с названием дня недели.
  3. Вывести название соответствующего дня недели.

Вот пример программы на Python, реализующей данный алгоритм:

python
# Запросить номер дня недели у пользователя day_number = int(input("Введите номер дня недели (1-7): ")) # Использовать условные операторы для сопоставления введенного значения с названием дня недели if day_number == 1: day_name = "понедельник" elif day_number == 2: day_name = "вторник" elif day_number == 3: day_name = "среда" elif day_number == 4: day_name = "четверг" elif day_number == 5: day_name = "пятница" elif day_number == 6: day_name = "суббота" elif day_number == 7: day_name = "воскресенье" else: day_name = "недействительный день" # Вывести название дня недели print("Это", day_name)

После запуска программы она будет запрашивать у пользователя ввести номер дня недели (от 1 до 7), а затем выведет название соответствующего дня недели.

Надеюсь, это поможет! Если у тебя есть ещё вопросы, не стесняйся спрашивать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос