Вопрос задан 23.10.2023 в 22:23.
Предмет Другие предметы.
Спрашивает Юрченко Иван.
Задача по информатике Составьте программу 1 ввести три числа найти наибольшее из них Пример
Введите три числа 4 15 9 Наибольшее 15 Плез сделайте в кумиреОтветы на вопрос
Отвечает Саутиева Елизавета.
var a, b, c: integer;
begin
writeln('Введите три числа:');
readln(a, b, c);
if (a > b) and (a > c) then writeln(a);
if (b > a) and (b > c) then writeln(b)
else writeln(c)
end.
Вот
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот программа на языке Кумир, которая позволяет ввести три числа и найти наибольшее из них:
kumirПрограмма Наибольшее_число; Подпрограмма Найти_Наибольшее(var a, b, c, max : целое); нач Если (a >= b) и (a >= c) То max := a; Иначе Если (b >= a) и (b >= c) То max := b; Иначе max := c; КонецЕсли; конец; нач var число1, число2, число3, наибольшее : целое; Вывод "Введите три числа: "; Ввод число1, число2, число3; Найти_Наибольшее(число1, число2, число3, наибольшее); Вывод "Наибольшее: ", наибольшее; конец.
Сначала мы создаем подпрограмму Найти_Наибольшее, которая принимает три числа и находит наибольшее из них. Затем в основной части программы мы вводим три числа от пользователя и вызываем эту подпрограмму для поиска наибольшего числа, после чего выводим результат.
Похожие вопросы
Топ вопросов за вчера в категории Другие предметы
Последние заданные вопросы в категории Другие предметы
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
