
Вопрос задан 26.04.2020 в 19:49.
Предмет Информатика.
Спрашивает Чернова Александра.
Помогите написать программу в Паскале. Дан массив размера N. Массив отсортировать в порядке
возрастания. Для отладки программы числа последовательностей сформировать с помощью генератора случайных чисел.

Ответы на вопрос

Отвечает Шашков Данил.
Uses Crt;
Const
N = 13;
Var
A:array[1..N] of integer;
i,j,Min,B:integer;
Begin
ClrScr;
Randomize;
Write('Исходный массив:');
For i:= 1 to N do
Begin
A[i]:=random(2*N+1)-N;
Write(' ',A[i])
End;
WriteLn;
Write('Отсортированный массив:');
For i:= 1 to N do
Begin
Min:=i;
For j:= i+1 to N do
if A[j] < A[Min] then Min:=j;
B:=A[i];
A[i]:=A[Min];
A[Min]:=B;
Write(' ',A[i])
End;
ReadLn
End.
Const
N = 13;
Var
A:array[1..N] of integer;
i,j,Min,B:integer;
Begin
ClrScr;
Randomize;
Write('Исходный массив:');
For i:= 1 to N do
Begin
A[i]:=random(2*N+1)-N;
Write(' ',A[i])
End;
WriteLn;
Write('Отсортированный массив:');
For i:= 1 to N do
Begin
Min:=i;
For j:= i+1 to N do
if A[j] < A[Min] then Min:=j;
B:=A[i];
A[i]:=A[Min];
A[Min]:=B;
Write(' ',A[i])
End;
ReadLn
End.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili