Вопрос задан 26.04.2020 в 09:38. Предмет Информатика. Спрашивает Ербатыров Алишер.

Напишите программу, в которой сортировка выполняется методом камня- самый тяжелый элемент

опускается в конец массива. в решение в паскаля
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Балашова Женя.
//Как учили наших дедов...

var
a:array[1..10000] of integer;
i,j,n, tmp : integer;
Begin
Writeln('Введите кол-во элементов в массиве');
Readln(n);
Writeln('Введите элеметы массива: ');
for i:= 1 to n do
  Read(a[i]);
for i:= 1 to n do
  for j:= 1 to n do
    if (a[i] < a[j]) then
    begin
      tmp:=a[i];
      a[i]:=a[j];
      a[j]:=tmp;
    end;
for i:= 1 to n do
  Write(a[i], ' ');
end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос