Вопрос задан 21.01.2020 в 06:07.
Предмет Информатика.
Спрашивает Короткова Аня.
Составьте программу, которая позволяет определить, равны ли длыны строк s и t между собой. строчки
введите с клавиатуры. Ответ должен быть выведен в виде "да" или "нет"Ответы на вопрос
Отвечает Миханова Софья.
Не указан язык) Сделал на с++ :)
p.s добавил паскаль
program HelloWorld;
var
s, t: string;
i, i2: integer;
begin
readln(s);
readln(t);
i:=length(s);
i2:=length(t);
if i > i2 then write('Да')
else write('Нет');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам с написанием программы на Python, которая сравнивает длины двух строк, введенных с клавиатуры. Вот пример кода:
```python # Ввод строк с клавиатуры s = input("Введите первую строку: ") t = input("Введите вторую строку: ")
# Определение длин строк и сравнение их между собой if len(s) == len(t): print("Да") else: print("Нет") ```
В этом коде используется функция `len()`, которая возвращает длину строки. Если длины строк `s` и `t` равны, программа выводит "Да", иначе "Нет".
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
