
Паскаль. Задайте массив из 10 случайных целых чисел из интервала [-5;5] .Определите сколько раз в
массиве встречается число 3

Ответы на вопрос

const
N=10;
var a: array [1..N] of integer;
i,count : integer;
begin
count:=0;
cls;
writeln ('Массив [-5;5]');
for i:=1 to N do begin
A[i]:=random (11)-5;
write (A[i]:4);
if A[i] = 3 then
count:=count+1;
end;
writeln;
writeln ('Количество троек в массиве : ', count);
end.



Для решения этой задачи на языке программирования Паскаль можно использовать следующий код:
```pascal program CountOccurrences; uses crt;
var arr: array[1..10] of integer; i, count: integer;
begin randomize; // Сбросить генератор случайных чисел
// Заполнение массива случайными числами от -5 до 5 for i := 1 to 10 do begin arr[i] := random(11) - 5; end;
// Подсчет количества вхождений числа 3 в массиве count := 0; for i := 1 to 10 do begin if arr[i] = 3 then count := count + 1; end;
// Вывод результата writeln('Массив:'); for i := 1 to 10 do begin write(arr[i], ' '); end; writeln; writeln('Число 3 встречается в массиве ', count, ' раз(а).');
readln; end. ```
В этом коде мы объявляем массив arr, состоящий из 10 целых чисел. Затем мы используем цикл for для заполнения массива случайными числами от -5 до 5 с помощью функции random(11) - 5. Далее мы используем еще один цикл for для подсчета количества вхождений числа 3 в массиве. Если текущий элемент массива arr[i] равен 3, мы увеличиваем счетчик count на 1. В конце мы выводим результаты: сначала выводим массив arr, а затем выводим количество вхождений числа 3 в массив.
Пример вывода: ``` Массив: -2 4 1 3 -5 0 3 -1 -3 -4 Число 3 встречается в массиве 2 раз(а). ```
Таким образом, в данном примере число 3 встречается в массиве два раза.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili