Вопрос задан 16.01.2020 в 12:20.
Предмет Информатика.
Спрашивает Рубцова Анастасия.
Помогите срочно написать программу в паскале.номер 7.даю 50 баллов

Ответы на вопрос
Отвечает Смоляр Максим.
// PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018
// Внимание! Если программа не работает, обновите версию!
1) точно по заданию
begin
var k := ReadInteger('k=');
Writeln('К оплате, руб: ', 2.0 + (k > 100 ? (k - 100) * 2.5 : 0.0))
end.
2) по логике так должно быть
begin
var k := ReadInteger('k=');
if k <= 100 then Writeln('К оплате, руб: ', 2.0 * k)
else Writeln('К оплате, руб: ', 200.0 + (k - 100) * 2.5)
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
