30 баллов Составьте программу для нахождения суммы трёх чисел, если хотя бы одно из них кратно 3,
иначе модуль разности этих чисел.Ответы на вопрос
var x1,x2,x3:integer;
begin
writeln('Введите три числа');
readln(x1,x2,x3);
if (x1 mod 3=0)or(x2 mod 3=0)or(x3 mod 3=0) then
writeln('Сумма трех чисел = ',x1+x2+x3)
else writeln('Модуль разности трех чисел = ',abs(x1-x2-x3));
end.
var a,b,c:integer;
begin
read (a,b,c);
if (a mod 3 = 0) or (b mod 3 = 0) or (c mod 3 = 0) then write (a+b+c)
else write (abs(a-b-c))
end.
Программа для нахождения суммы трех чисел, если хотя бы одно из них кратно 3, иначе модуль разности этих чисел, может быть следующей:
1. Запросить у пользователя ввод трех чисел и сохранить их в переменные a, b и c. 2. Проверить, кратно ли хотя бы одно из чисел 3. Для этого используем оператор условия if и операторы сравнения с остатком от деления на 3. 3. Если хотя бы одно из чисел кратно 3, то вычислить сумму трех чисел, сохранить результат в переменную sum и вывести на экран. 4. Если ни одно из чисел не кратно 3, то вычислить модуль разности этих чисел, сохранить результат в переменную diff и вывести на экран.
Ниже приведен пример программы на языке Python:
```python a = int(input("Введите первое число: ")) b = int(input("Введите второе число: ")) c = int(input("Введите третье число: "))
if a % 3 == 0 or b % 3 == 0 or c % 3 == 0: sum = a + b + c print("Сумма трех чисел равна:", sum) else: diff = abs(a - b - c) print("Модуль разности трех чисел равен:", diff) ```
В этой программе мы сначала запрашиваем у пользователя ввод трех чисел и сохраняем их в переменные a, b и c. Затем мы проверяем, кратно ли хотя бы одно из чисел 3, используя оператор условия if и операторы сравнения с остатком от деления на 3. Если хотя бы одно из чисел кратно 3, мы вычисляем сумму трех чисел и выводим результат на экран. Если ни одно из чисел не кратно 3, мы вычисляем модуль разности этих чисел, используя функцию abs() для получения абсолютного значения, и выводим результат на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
