 
найти сумму элементов целочисленного массива. помогите пожалуйста программу составить на паскале
 0
        0
         0
        0
    Ответы на вопрос
 
        var k:array[1..10] of integer;
var s:real;
var i:integer;
begin
for i:=1 to 10 do begin
k[i]:=round(10*random+3);
s:=s+k[i];
end;
write('Сумма массива = ', s);
writeln
end.
Должно работать, проверьте.
 0
                    0
                     0
                    0
                 
            Для нахождения суммы элементов целочисленного массива на языке Паскаль, вам потребуется написать программу. Вот пример программы на Паскале, которая находит сумму элементов массива:
```pascal program SumOfArrayElements;
const n = 5; // размер массива
var arr: array[1..n] of integer; // объявление массива i, sum: integer; // переменные для цикла и суммы
begin // заполнение массива arr[1] := 10; arr[2] := 20; arr[3] := 30; arr[4] := 40; arr[5] := 50;
// вычисление суммы элементов массива sum := 0; for i := 1 to n do begin sum := sum + arr[i]; end;
// вывод результата writeln('Сумма элементов массива: ', sum);
// ожидание ввода, чтобы программа не закрылась сразу readln; end. ```
В этом примере программа объявляет массив `arr` размером 5 элементов и заполняет его значениями от 10 до 50. Затем она проходит по всем элементам массива в цикле и суммирует их значения. Результат выводится на экран.
Обратите внимание, что в данном примере размер массива и его значения заданы явно в коде программы. Если вам нужно вводить размер массива и его значения с клавиатуры, вам потребуется добавить соответствующий код для ввода данных.
Надеюсь, это поможет вам составить программу на Паскале для нахождения суммы элементов целочисленного массива. Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать их!
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			