
Вопрос задан 22.05.2019 в 07:21.
Предмет Информатика.
Спрашивает Гейдер Костя.
ПРОГРАММИСТЫ ВЫРУЧАЙТЕ!Напишите программу, по которой будут введены данные из файла, и выполнена
следующая обработка: 1) определение среднего роста и среднего веса всех учеников; 2) вывод на экран и в файл rost.txt списка (фамилии, имена, возраст) учеников, рост которых выше среднего; 3) вывод на экран и в файл ves.txt списка учеников, вес которых ниже среднего.

Ответы на вопрос

Отвечает Фоменко Елизавета.
//PascalABC.NET 3.0, сборка 1088
begin
var a:=ReadLines('infile.txt').ToArray;
var n:=a.Length;
Writeln('*** Исходная информация ***');
// фамилия, имя, возраст, рост, вес
a.PrintLn(NewLine);
Writeln('*** Задание 1 ***');
var sves:real:=0;
var srost:real:=0;
foreach var s in a do begin
srost+=StrToFloat(s.ToWords.ElementAt(3));
sves+=StrToFloat(s.ToWords.ElementAt(4))
end;
Writeln('Средний рост равен ',srost/n:5:1);
Writeln('Средний вес равен ',sves/n:4:1);
srost/=n; sves/=n;
Writeln('*** Задание 2 ***');
var f2:=OpenWrite('rost.txt');
foreach var s in a do begin
var ss:=s.ToWords;
var rost:=StrToFloat(ss.ElementAt(3));
if rost>srost then begin
var s0:=ss.Take(3).ToArray;
var s1:=s0[0]+' '+s0[1]+', '+s0[2];
Writeln(s1);
Writeln(f2,s1)
end
end;
f2.Close;
Writeln('*** Задание 3 ***');
f2:=OpenWrite('ves.txt');
foreach var s in a do begin
var ss:=s.ToWords;
var ves:=StrToFloat(ss.ElementAt(4));
if ves<sves then begin
var s0:=ss.Take(3).ToArray;
var s1:=s0[0]+' '+s0[1]+', '+s0[2];
Writeln(s1);
Writeln(f2,s1)
end
end;
f2.Close
end.
Тестовое решение:
*** Исходная информация ***
Иванов Игорь 14 158 47.4
Петров Павел 14 161 58.3
Козлов Кирилл 15 160 60.3
Сидорова Мария 14 156 45.9
Тяпкина Наталья 15 158 46
Ляпкин Алексей 15 161 58.6
Мамочкин Константин 14 157 52.8
*** Задание 1 ***
Средний рост равен 158.7
Средний вес равен 52.8
*** Задание 2 ***
Петров Павел, 14
Козлов Кирилл, 15
Ляпкин Алексей, 15
*** Задание 3 ***
Иванов Игорь, 14
Сидорова Мария, 14
Тяпкина Наталья, 15
begin
var a:=ReadLines('infile.txt').ToArray;
var n:=a.Length;
Writeln('*** Исходная информация ***');
// фамилия, имя, возраст, рост, вес
a.PrintLn(NewLine);
Writeln('*** Задание 1 ***');
var sves:real:=0;
var srost:real:=0;
foreach var s in a do begin
srost+=StrToFloat(s.ToWords.ElementAt(3));
sves+=StrToFloat(s.ToWords.ElementAt(4))
end;
Writeln('Средний рост равен ',srost/n:5:1);
Writeln('Средний вес равен ',sves/n:4:1);
srost/=n; sves/=n;
Writeln('*** Задание 2 ***');
var f2:=OpenWrite('rost.txt');
foreach var s in a do begin
var ss:=s.ToWords;
var rost:=StrToFloat(ss.ElementAt(3));
if rost>srost then begin
var s0:=ss.Take(3).ToArray;
var s1:=s0[0]+' '+s0[1]+', '+s0[2];
Writeln(s1);
Writeln(f2,s1)
end
end;
f2.Close;
Writeln('*** Задание 3 ***');
f2:=OpenWrite('ves.txt');
foreach var s in a do begin
var ss:=s.ToWords;
var ves:=StrToFloat(ss.ElementAt(4));
if ves<sves then begin
var s0:=ss.Take(3).ToArray;
var s1:=s0[0]+' '+s0[1]+', '+s0[2];
Writeln(s1);
Writeln(f2,s1)
end
end;
f2.Close
end.
Тестовое решение:
*** Исходная информация ***
Иванов Игорь 14 158 47.4
Петров Павел 14 161 58.3
Козлов Кирилл 15 160 60.3
Сидорова Мария 14 156 45.9
Тяпкина Наталья 15 158 46
Ляпкин Алексей 15 161 58.6
Мамочкин Константин 14 157 52.8
*** Задание 1 ***
Средний рост равен 158.7
Средний вес равен 52.8
*** Задание 2 ***
Петров Павел, 14
Козлов Кирилл, 15
Ляпкин Алексей, 15
*** Задание 3 ***
Иванов Игорь, 14
Сидорова Мария, 14
Тяпкина Наталья, 15


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili