
Вопрос задан 21.05.2019 в 13:01.
Предмет Информатика.
Спрашивает Лосякова Юлия.
Надо написать программу на Паскале, без массивов. Дано натуральное число. Определить, сколько раз у
этого числа встречается минимальная цифра. (Например, при вводе числа 2618319, на экране должно быть "2").

Ответы на вопрос

Отвечает Кузьменко Женя.
Var
s:string;
c:char;
i,k:integer;
begin
Write('Введите число: '); Readln(s);
c:=s[1]; k:=1;
for i:=2 to length(s) do
if s[i]=c then Inc(k)
else if s[i]<c then begin c:=s[i]; k:=1 end;
Writeln('Наименьшая цифра ',c,' встретилась ',k,' раз(а)')
end.
Тестовое решение:
Введите число: 3141592653589793
Наименьшая цифра 1 встретилась 2 раз(а)
s:string;
c:char;
i,k:integer;
begin
Write('Введите число: '); Readln(s);
c:=s[1]; k:=1;
for i:=2 to length(s) do
if s[i]=c then Inc(k)
else if s[i]<c then begin c:=s[i]; k:=1 end;
Writeln('Наименьшая цифра ',c,' встретилась ',k,' раз(а)')
end.
Тестовое решение:
Введите число: 3141592653589793
Наименьшая цифра 1 встретилась 2 раз(а)



Отвечает Селивёрстова Дарья.
Var a, k, count: integer;
begin
readln(a);
k:=a mod 10;
a:=a div 10;
count:=1;
while(a<>0) do begin
if(a mod 10 = k) then count+=1;
if(a mod 10 < k) then begin
k:=a mod 10;
count:=1;
end;
a:=a div 10;
end;
writeln(count);
end.
begin
readln(a);
k:=a mod 10;
a:=a div 10;
count:=1;
while(a<>0) do begin
if(a mod 10 = k) then count+=1;
if(a mod 10 < k) then begin
k:=a mod 10;
count:=1;
end;
a:=a div 10;
end;
writeln(count);
end.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili