 
Вопрос задан 17.05.2019 в 22:05.
Предмет Информатика.
Спрашивает Бигожин Вадим.
Дан целочисленный массив a размера n. Вывести порядковый номер последнего из тех его элементов ak,
которые удовлетворяют двойному неравенству a1 < ak < a10. Если таких элементов нет, то вывести 0. Входные данные: ввести одно целое число n. (1<=n<=1000). Далее ввести n чисел в диапазоне от -1000 до 1000. Выходные данные: вывести порядковый номер последнего из тех его элементов ak, которые удовлетворяют двойному неравенству a1 < ak < an. Если таких элементов нет, то вывести 0. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Мишагина Ксения.
                
     #include <iostream>
 
int main()
{
// Считываем.
int n;
std::cin >> n;
int * a = new int[n];
int t;
int i = 0;
while (n - i){
if (std::cin >> t){
a[i++] = t;
}
}
    
// Находим и выводим.
n--;
int max = -1;
for (i = n-1; i >= 0; --i){
if (a[i] > *a && a[i] < a[n]){
max = i;
break;
}
}
std::cout << max+1 << std::endl;
delete [] a;
std::cin.get();
std::cin.get();
return 0;
}
                                        int main()
{
// Считываем.
int n;
std::cin >> n;
int * a = new int[n];
int t;
int i = 0;
while (n - i){
if (std::cin >> t){
a[i++] = t;
}
}
// Находим и выводим.
n--;
int max = -1;
for (i = n-1; i >= 0; --i){
if (a[i] > *a && a[i] < a[n]){
max = i;
break;
}
}
std::cout << max+1 << std::endl;
delete [] a;
std::cin.get();
std::cin.get();
return 0;
}
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			