Вопрос задан 12.05.2019 в 04:24. Предмет Информатика. Спрашивает Кокарева Ангелина.

Дан массив состоящий из целых чисел, напишите программу на языке программирования Java, которая

выводит четные числа. Помогите пожалуйста.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Елубай Жулдыз.
Public class isEven {
public static void main(String args[]) {
int n = 9; //тут твоё число
if(n % 2 == 0) {
System.out.println("Число " + n + " четное");
} else {
System.out.println("Число " + n + " нечетное");
}
}
}
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Java, которая выводит четные числа из заданного массива:

```java public class EvenNumbers { public static void main(String[] args) { int[] numbers = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10}; System.out.println("Even numbers:"); for (int number : numbers) { if (number % 2 == 0) { System.out.println(number); } } } } ```

В этой программе мы объявляем массив `numbers`, содержащий целые числа. Затем мы используем цикл `for-each` для перебора всех элементов массива. Внутри цикла мы проверяем, является ли текущее число четным, используя оператор `%` для определения остатка от деления на 2. Если остаток равен 0, то число четное, и мы выводим его на экран.

Примечание: В данном примере используется фиксированный массив `numbers`, но вы можете изменить его на свой собственный массив или ввести числа с клавиатуры.

Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос