Вопрос задан 05.05.2019 в 11:36. Предмет Информатика. Спрашивает Андерсон Рома.

Написать программу нахождения наиболее наибольшего из трех чисел PASCAL

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Рахметова Зарина.
Program chisla;
var a,b,c,max:real;
begin
readln(a,b,c);
if (a>b) and (a>c) then max:=a;
if (a<b) and (b>c) then max:=b
if (a<c) and (b<c) then max:=c;
writeln(max);
end.
0 0
Отвечает Смирнов Евгений.
Program chik;
var a,b,c,min:real;
begin
read(a,b,c);
min:=a;
if(b>min)then min:=b;
if(c>min)then min:=c;
writeln(min);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа нахождения наибольшего из трех чисел на Pascal

Вот пример программы на языке Pascal, которая находит наибольшее из трех чисел:

```pascal program FindLargestNumber; var num1, num2, num3, largest: integer; begin writeln('Введите первое число: '); readln(num1); writeln('Введите второе число: '); readln(num2); writeln('Введите третье число: '); readln(num3); largest := num1; if num2 > largest then largest := num2; if num3 > largest then largest := num3; writeln('Наибольшее число: ', largest); end. ```

В этой программе мы объявляем переменные `num1`, `num2`, `num3` и `largest` типа `integer`. Затем мы запрашиваем у пользователя ввод трех чисел и сохраняем их в соответствующих переменных.

Далее мы инициализируем переменную `largest` значением `num1`. Затем мы сравниваем `num2` с `largest` и, если `num2` больше, присваиваем `largest` значение `num2`. Затем мы сравниваем `num3` с `largest` и, если `num3` больше, присваиваем `largest` значение `num3`.

Наконец, мы выводим наибольшее число на экран с помощью `writeln`.

Примечание: Это только один из возможных способов решения задачи. В зависимости от ваших требований, вы можете использовать другие алгоритмы или структуры данных для решения этой задачи.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос