Составить программу в Pascal для вычисления функции : 1) y=sin(x^2+1) 2) y= квадратный корень из
x^3+2x 3) y=(x+8)/(x^3-4)Ответы на вопрос
var x: real; read(x); writeln('y(',x,') = sin(',x,'^2+1) = ',sin(sqr(x)+1)); writeln('y(',x,') = sqrt(',x,'^3+2x) = ',sqrt(power(x,3)+2*x)); writeln('y(',x,') = (x+8)/(x^3-4) = ',(x+8)/(power(x,3)-4));
end.
Program in Pascal for Computing Functions
Here's a Pascal program to compute the given functions:
1. Function 1: - Function: \( y = \sin(x^2 + 1) \) - Pascal code: ``` function Function1(x: real): real; begin Function1 := sin(sqr(x) + 1); end; ```
2. Function 2: - Function: \( y = \sqrt{x^3 + 2x + 3} \) - Pascal code: ``` function Function2(x: real): real; begin Function2 := sqrt(x * x * x + 2 * x + 3); end; ```
3. Function 3: - Function: \( y = \frac{x + 8}{x^3 - 4} \) - Pascal code: ``` function Function3(x: real): real; begin Function3 := (x + 8) / (x * x * x - 4); end; ```
You can use these functions in your Pascal program to compute the respective values based on the input.
Let me know if you need further assistance!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
