
Нужно написать программу на языке паскаль по условию: Найти сумму элементов массива расположенных
до последнего положительного элемента Буду бескрайне благодарна, если поможете мне))

Ответы на вопрос

var a,b:array[1..100] of integer; i,j,k,n:integer;
procedure rmassr;
begin
for i:=1 to n do begin
a[i]:=random(10);
end;
end;
procedure rmassy;
begin
for i:=1 to n do begin
readln(a[i]);
end;
end;
procedure rmass();
begin
for i:=1 to n do begin
write(a[i],' ');
end;
end;
procedure newmass;
begin
for i:=1 to n do begin
if a[i] > 0 then b[i]:=a[i];
end;
for i:=1 to n do begin
j:=j+b[i];
end;
writeln('summa = ',j);
end;
begin
clrscr;
randomize;
write('длина массива '); readln(n);
write('1-random; 2-в ручную'); readln(k);
if k = 1 then
rmassr()
else rmassy();
rmass();
writeln();
newmass();
readln
end.



Конечно, я могу помочь с написанием программы на языке Паскаль по данному условию. Программа будет выглядеть примерно так:
```pascal program SumBeforeLastPositiveElement;
const N = 10; // размер массива var arr: array[1..N] of integer; i, sum: integer;
begin // заполняем массив случайными числами (для примера) Randomize; for i := 1 to N do arr[i] := Random(20) - 10; // случайные числа от -10 до 10
// выводим исходный массив writeln('Исходный массив:'); for i := 1 to N do write(arr[i], ' '); writeln;
// ищем последний положительный элемент и считаем сумму элементов до него i := 1; sum := 0; while (i <= N) and (arr[i] <= 0) do begin sum := sum + arr[i]; i := i + 1; end;
// выводим сумму элементов до последнего положительного элемента writeln('Сумма элементов до последнего положительного элемента: ', sum); end. ```
В данной программе мы создаем массив из 10 элементов, заполняем его случайными числами от -10 до 10 и находим сумму элементов до последнего положительного элемента. Надеюсь, это поможет вам!


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili