
Составьте программу в паскаль с помощью while. Стакан кипятка (100 °С) остыл за первую минуту на А
градусов, а каждую последующую минуту остывал на 15% меньше, чем в предыдущую. Через сколько минут температура воды станет ниже Nо С?

Ответы на вопрос

Begin
Writeln('Введите A градусов');
readln(A);
Writeln('До какой температуры остужать:');
readln(N);
gradus:=100-A;minut:=1;
While (gradus>N) do
Begin
A:=A*(1-0.15);
gradus:=gradus-A;
minut:=minut+1;
end;
Writeln('Кипяток остынет до ',N,' градусов через ', minut, ' минут');
readln();
end.



Program in Pascal using a while loop to calculate the time it takes for the temperature of water to drop below a certain value
Here's a program written in Pascal that uses a while loop to calculate the time it takes for the temperature of water to drop below a certain value:
```pascal program WaterTemperature; var initialTemperature, currentTemperature, targetTemperature: real; time: integer; begin initialTemperature := 100; // Initial temperature of the water in degrees Celsius targetTemperature := 70; // Target temperature in degrees Celsius currentTemperature := initialTemperature; time := 0;
while currentTemperature > targetTemperature do begin currentTemperature := currentTemperature - (currentTemperature * 0.15); // Decrease temperature by 15% each minute time := time + 1; // Increment time by 1 minute end;
writeln('The temperature of the water will drop below ', targetTemperature:0:2, ' degrees Celsius after ', time, ' minutes.'); end. ```
In this program, we initialize the initial temperature of the water to 100 degrees Celsius and the target temperature to 70 degrees Celsius. We use a while loop to continuously decrease the current temperature by 15% each minute until it drops below the target temperature. The time variable keeps track of the number of minutes it takes for the temperature to drop below the target temperature. Finally, we display the result using the `writeln` statement.
Please note that the program assumes a constant rate of temperature decrease of 15% each minute. If the rate of temperature decrease changes over time, the program may not provide an accurate result.
I hope this helps! Let me know if you have any further questions.


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili