Составьте программу в которой с клавиатуры вводится 3 числа и программа выводит наибольшее из них,
а если они равны, то пишет, что равны.Ответы на вопрос
Var a,b,c:integer;
Begin
Readln(a,b,c);
if (a>b) and (a>c) then Writeln(a);
if (b>a) and (b>c) then Writeln(b);
if (c>a) and (c>b) then Writeln(c);
if (a=b) and (b=c) then Writeln('Числа равны');
End.
Program to Find the Largest Number
Here's a simple program in Java that takes three numbers as input from the keyboard and outputs the largest number among them. If the numbers are equal, it will print that they are equal.
```java import java.util.Scanner;
public class Main { public static void main(String[] args) { Scanner input = new Scanner(System.in);
System.out.println("Enter three numbers: "); int num1 = input.nextInt(); int num2 = input.nextInt(); int num3 = input.nextInt();
if (num1 > num2 && num1 > num3) { System.out.println("The largest number is: " + num1); } else if (num2 > num1 && num2 > num3) { System.out.println("The largest number is: " + num2); } else if (num3 > num1 && num3 > num2) { System.out.println("The largest number is: " + num3); } else { System.out.println("The numbers are equal."); } } } ```
This program uses the Scanner class to take input from the user and then compares the numbers to find the largest one. If the numbers are equal, it prints that they are equal.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
