Вопрос задан 01.04.2019 в 17:28.
Предмет Информатика.
Спрашивает Рыжкова Екатерина.
Напишите программу,которая переставляет первую и последнюю цифры, введённого число,например,из
числа 12345 должно получится 52341. Pascal ABC. Пожалуйста,с объяснениемОтветы на вопрос
Отвечает Дауылбаева Айгерим.
ДЛЯ ЧЕТЫРЕХЗНАЧНЫХ ЧИСЕЛ:
var x: integer;
begin
writeln ('Введите четырехзначное число.');
read (x);
x:=x mod 10 * 1000 + x div 100 mod 10 * 100 + x div 10 mod 10 * 10 + x div 1000;
writeln ('Число после перестановки цифр:',x);
end.
ДЛЯ ЛЮБЫХ ЧИСЕЛ:
program znanija;
var n,m,c1,cp:integer;
k,i:byte;
begin
write('Введите число.');
readln(n);{например 12345}
cp:=n mod 10;{последняя цифра=5}
n:=n div 10;{число без последней цифры=1234}
m:=n;{запомним его}
k:=0;
while m>9 do{пока не останется 1 цифра}
begin
m:=m div 10;{первая цифра=1}
k:=k+1;{количество разрядов без первого=4}
end;
c1:=m;{запомним первую цифру=1}
for i:=1 to k do
begin
m:=m*10;{повышаем разряд числа, равного первой цифре=1000}
cp:=cp*10;{повышаем разряд последней цифры=5000}
end;
n:=(n-m)*10+c1+cp*10;{получаем число=(1234-1000)*10+1+5000*10=52341}
writeln('Число после перестановки цифр:',n);
end.
var x: integer;
begin
writeln ('Введите четырехзначное число.');
read (x);
x:=x mod 10 * 1000 + x div 100 mod 10 * 100 + x div 10 mod 10 * 10 + x div 1000;
writeln ('Число после перестановки цифр:',x);
end.
ДЛЯ ЛЮБЫХ ЧИСЕЛ:
program znanija;
var n,m,c1,cp:integer;
k,i:byte;
begin
write('Введите число.');
readln(n);{например 12345}
cp:=n mod 10;{последняя цифра=5}
n:=n div 10;{число без последней цифры=1234}
m:=n;{запомним его}
k:=0;
while m>9 do{пока не останется 1 цифра}
begin
m:=m div 10;{первая цифра=1}
k:=k+1;{количество разрядов без первого=4}
end;
c1:=m;{запомним первую цифру=1}
for i:=1 to k do
begin
m:=m*10;{повышаем разряд числа, равного первой цифре=1000}
cp:=cp*10;{повышаем разряд последней цифры=5000}
end;
n:=(n-m)*10+c1+cp*10;{получаем число=(1234-1000)*10+1+5000*10=52341}
writeln('Число после перестановки цифр:',n);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
