Вопрос задан 22.03.2019 в 11:37.
Предмет Информатика.
Спрашивает Котик Оля.
Составьте программу вычисляющую, сумму квадратов чисел от 1 до n, (n- вводится с клавиатуры) если
n-четное, и сумму кубов чисел от 1 до n, если n-нечетное1 Использовать цикл REPEATОтветы на вопрос
Отвечает Марчук Ульна.
var i,x,n:integer;
begin
i:=1;
writeln('Vvedit N');
readln(n);
if n mod 2 = 0 then begin
repeat
x:=i*i+x;
i:=i+1;
until i>n;
end
else begin
repeat
x:=i*i*i+x;
i:=i+1;
until i>n;
end;
writeln(x);
readln;
end.
Топ вопросов за вчера в категории Информатика
Информатика 143
Информатика 285
Информатика 32
Информатика 56
Информатика 381
Информатика 178
Информатика 2232
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
