
Вопрос задан 20.03.2019 в 07:09.
Предмет Информатика.
Спрашивает Вилпер Алёна.
Составить задачу по паскалю абс Назовем слово А следом слова В, если В можно составтиь из букв,
входящих в А, при этом каждая буква в В может использоватся не чаще, чем она астречается в А. Например, слово "УЛЬТРАМАРИН" - след слова "ЛАНИТА" или "МИР", но не является следом слова "МЕРА" (оно содержит букву "Е", которой нет в слове "УЛЬТРАМАРИН") или "РИММА" (буква "М" здесь встречается двва раза, а вслове "УЛЬТРАМАРИН" - один раз). Задаются два слова Х и У. Следует проверить, является ли слово У следом слова Х. Извествно, что оба слова содержат прописные буквы латинского алфавита и имеют длину до 30 симвлов. Формат ввода: Х У Формат вывода: Сообщение "YES", если слово У является следом слова Х Сообщение "NO", если слово не является следом слова Х

Ответы на вопрос

Отвечает Пешкова Татьяна.
Var x,y: string; l,k,i:integer;
begin
readln(x);
readln(y);
l:=length(x);
k:=0;
for i:=1 to l do
if pos(x[i],y)>0 then
begin
delete(y,pos(x[i],y),1);
k:=k+1;
end;
if k=l then writeln('YES') else writeln('NO');
end.
Пример:
MAMAPROGRAMMA
YES
begin
readln(x);
readln(y);
l:=length(x);
k:=0;
for i:=1 to l do
if pos(x[i],y)>0 then
begin
delete(y,pos(x[i],y),1);
k:=k+1;
end;
if k=l then writeln('YES') else writeln('NO');
end.
Пример:
MAMAPROGRAMMA
YES


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili