
Напишите программу, которая задает трехмерный массив и находит в нем наибольшее число. ( pascal ).
Буду очень рад, если прокомментируете, очень хочу разобраться.

Ответы на вопрос

const
n = 3;
var
a:array[1..n, 1..n, 1..n] of integer; //объявляем трехмерный массив размерности N x N x N
i, j, k, max:integer;
begin
randomize;
max := -maxint - 1; {присваисваем maxrcbvfkmyjve 'ktvtyne минимальное возможное значения типа integer}
for i := 1 to n do { с помощью трех циклов проходим по всем элементам массива, чобственно тоже самое что и с двумерным массивом только добаляемтся еще 1 цикл}
begin
writeln;
writeln('i = ', i); {выводм масссива производится в виде нескольких квадратных матриц тут указывается номер каждой квадратной матрицы}
for j := 1 to n do
begin
for k := 1 to n do
begin
a[i, j, k] := random(21) - 10; // генерируем случайное значение от -10 до 10
if a[i, j, k] > max then { если больше текущего максимального то станвится новым максимальным}
max := a[i, j, k];
write(a[i, j, k]:4); //выводим элемент массива
end;
writeln;
end;
end;
writeln('Максимальный элемент массива равен ', max);
end.



Конечно, я могу помочь с написанием программы на Pascal, которая находит наибольшее число в трехмерном массиве. Вот код программы с подробными комментариями:
```pascal program FindMaxNumber;
const MAX_SIZE = 3; // размеры трехмерного массива
type TThreeDimensionalArray = array[1..MAX_SIZE, 1..MAX_SIZE, 1..MAX_SIZE] of Integer;
// Функция для нахождения наибольшего числа в трехмерном массиве function FindMaxNumberInArray(arr: TThreeDimensionalArray): Integer; var i, j, k: Integer; maxNumber: Integer; begin maxNumber := arr[1, 1, 1]; // Предполагаем, что первый элемент массива является наибольшим
// Проходим по всем элементам массива и сравниваем их с наибольшим числом for i := 1 to MAX_SIZE do begin for j := 1 to MAX_SIZE do begin for k := 1 to MAX_SIZE do begin if arr[i, j, k] > maxNumber then maxNumber := arr[i, j, k]; end; end; end;
FindMaxNumberInArray := maxNumber; // Возвращаем наибольшее число end;
var arr: TThreeDimensionalArray; i, j, k: Integer;
begin // Заполняем трехмерный массив случайными числами Randomize; for i := 1 to MAX_SIZE do begin for j := 1 to MAX_SIZE do begin for k := 1 to MAX_SIZE do begin arr[i, j, k] := Random(100); // Генерируем случайное число от 0 до 99 end; end; end;
// Выводим трехмерный массив на экран for i := 1 to MAX_SIZE do begin for j := 1 to MAX_SIZE do begin for k := 1 to MAX_SIZE do begin Write(arr[i, j, k], ' '); end; Writeln; end; Writeln; end;
// Находим наибольшее число в трехмерном массиве Writeln('Наибольшее число в трехмерном массиве: ', FindMaxNumberInArray(arr)); end. ```
В этой программе мы используем трехмерный массив `TThreeDimensionalArray`, размером `MAX_SIZE x MAX_SIZE x MAX_SIZE`.
Функция `FindMaxNumberInArray` принимает трехмерный массив и возвращает наибольшее число в этом массиве. Мы предполагаем, что первый элемент массива является наибольшим, а затем сравниваем его со всеми остальными элементами массива. Если находим число, большее текущего максимального числа, обновляем значение `maxNumber`.
В основной части программы мы создаем трехмерный массив `arr` и заполняем его случайными числами от 0 до 99 с помощью функции `Random`. Затем выводим массив на экран.
Наконец, вызываем функцию `FindMaxNumberInArray` и выводим наибольшее число в трехмерном массиве.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili