Составьте программу нахождения суммы n произвольных чисел (число n ввести с клавиатуры). p.s pascal
ABCОтветы на вопрос
Программа нахождения суммы n произвольных чисел
Для написания программы нахождения суммы n произвольных чисел на языке Pascal ABC, вы можете использовать следующий код:
```pascal program SumOfNumbers; var n, i, number, sum: integer; begin write('Введите количество чисел (n): '); readln(n); sum := 0; for i := 1 to n do begin write('Введите число ', i, ': '); readln(number); sum := sum + number; end; writeln('Сумма введенных чисел: ', sum); end. ```
В этой программе мы сначала запрашиваем у пользователя количество чисел (n), которые он хочет ввести. Затем мы используем цикл `for` для повторения ввода чисел n раз. В каждой итерации цикла мы запрашиваем у пользователя число и добавляем его к переменной `sum`, которая хранит сумму введенных чисел. По завершении цикла, программа выводит итоговую сумму.
Например, если пользователь вводит n = 3 и числа 5, 10 и 15, программа выведет сумму 30.
Примечание: В коде используется функция `readln` для чтения чисел с клавиатуры. Убедитесь, что ваша среда разработки поддерживает эту функцию.
Надеюсь, это поможет вам написать программу нахождения суммы n произвольных чисел на языке Pascal ABC! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
