Паскаль ABC.Net Дан произвольный текст на русском языке. Написать программу, которая выводит слова,
начинающиеся на согласную и заканчивающиеся гласной буквой.Пожалуйста,с комментариями где можноОтветы на вопрос
        // Внимание! Если программа не работает, обновите версию!
begin
var pic:='\b[бвгджзйклмнпрстфхцчшщъь]\S*[аеёиоуыэюя]\b';
ReadlnString('Введите:').MatchValues(pic,RegexOptions.IgnoreCase)
.Println(NewLine)
end.
Пример
Введите: А роза упала на лапу Азора, а Карл у Клары украл кораллы.
роза
на
лапу
Клары
кораллы
        Text,S:string;
n,k:boolean;
i:integer;
Begin
Write('Введите текст на русском языке: ');ReadLn(Text);
Text:=LowerCase(Text)+' '; // перевоит текст в нижний регистр
WriteLn(Text); // показывает действие предыдущей строки
For i:= 1 to Length(Text) do
Begin
if ('а' <= Text[i])and(Text[i] <= 'я')or(Text[i] = 'ё') then S:=S+Text[i] // записываем русские буквы в S
else // как только встречаем другой символ, проверяем,
if Length(S) > 0 then // есть ли в S хоть одна буква,
Begin // и если есть, то проверяем условие задачки, и выводим слово на экран, если оно истинно
if (S[1] in 'бвгджзйклмнпрстфхцчшщ')and(S[Length(S)] in 'аоэиуыеёюя') then WriteLn(S);
S:=''; // далее обнуляем S
End;
End;
End.
Пример работы программы:
Введите текст на русском языке: Дан произвольный текст на русском языке. Написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
дан произвольный текст на русском языке. написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
на
программу
которая
слова
начинающиеся
на
согласную
заканчивающиеся
            Программа на PascalABC.NET для вывода слов, начинающихся на согласную и заканчивающихся гласной буквой
Ниже приведена программа на PascalABC.NET, которая выводит слова из произвольного текста, начинающиеся на согласную букву и заканчивающиеся на гласную букву. Комментарии в программе объясняют каждый шаг.
```pascal program FindWords; uses crt;
// Функция для проверки, является ли символ согласной буквой function IsConsonant(ch: char): boolean; begin // Проверяем, является ли символ согласной буквой // В данном случае, считаем, что символ согласной, если он не является гласной IsConsonant := not (ch in ['a', 'e', 'i', 'o', 'u', 'y', 'а', 'е', 'ё', 'и', 'о', 'у', 'ы', 'э', 'ю', 'я']); end;
// Функция для проверки, является ли символ гласной буквой function IsVowel(ch: char): boolean; begin // Проверяем, является ли символ гласной буквой // В данном случае, считаем, что символ гласной, если он не является согласной IsVowel := not IsConsonant(ch); end;
// Функция для проверки, является ли символ буквой function IsLetter(ch: char): boolean; begin // Проверяем, является ли символ буквой IsLetter := (ch in ['a'..'z', 'A'..'Z', 'а'..'я', 'А'..'Я']); end;
// Процедура для поиска слов, начинающихся на согласную и заканчивающихся на гласную procedure FindWordsInText(text: string); var word: string; i: integer; begin word := ''; for i := 1 to Length(text) do begin // Если символ является буквой, добавляем его к текущему слову if IsLetter(text[i]) then word := word + text[i] else begin // Если текущее слово не пустое и начинается на согласную и заканчивается на гласную, // выводим его на экран if (Length(word) > 0) and IsConsonant(word[1]) and IsVowel(word[Length(word)]) then writeln(word); word := ''; end; end; end;
var text: string; begin // Очищаем экран clrscr; // Вводим произвольный текст writeln('Введите произвольный текст:'); readln(text); // Ищем слова, начинающиеся на согласную и заканчивающиеся на гласную writeln('Слова, начинающиеся на согласную и заканчивающиеся на гласную:'); FindWordsInText(text); // Ожидаем нажатия клавиши перед выходом writeln('Нажмите любую клавишу для выхода...'); readkey; end. ```
Программа начинается с определения трех вспомогательных функций: `IsConsonant`, `IsVowel` и `IsLetter`. Функция `IsConsonant` проверяет, является ли символ согласной буквой, функция `IsVowel` проверяет, является ли символ гласной буквой, а функция `IsLetter` проверяет, является ли символ буквой.
Затем, в процедуре `FindWordsInText`, происходит поиск слов, начинающихся на согласную и заканчивающихся на гласную. Процедура проходит по каждому символу в тексте и формирует слово, добавляя символы, пока не встретит символ, который не является буквой. Затем, если текущее слово не пустое и начинается на согласную и заканчивается на гласную, оно выводится на экран.
В основной части программы, пользователю предлагается ввести произвольный текст, а затем вызывается процедура `FindWordsInText` для поиска слов, удовлетворяющих условию. Результат выводится на экран.
Примечание: Данная программа предназначена для работы с русским языком, поэтому проверка на согласные и гласные буквы осуществляется для русских символов. Если вам необходимо работать с другим языком, вам может потребоваться изменить проверку символов в функциях `IsConsonant` и `IsVowel`.
Надеюсь, эта программа поможет вам решить вашу задачу! Если у вас возникнут еще вопросы, не стесняйтесь задавать их.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			