Вопрос задан 22.02.2019 в 20:29. Предмет Информатика. Спрашивает Игнаев Родион.

Напишите программу которая находит все целые числа от 200 до 500 у которвх ровно 6 делитилей на

языке паскаль
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Чайка Александра.
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  for var n:=200 to 500 do begin
    var k:=2;
    for var i:=2 to n div 2 do
    if n mod i=0 then
      k+=1;
    if k=6 then Print(n)
    end;
  Writeln
end.

Результат
207 212 236 242 243 244 245 261 268 275 279 284 292 316 325 332 333 338 356 363 369 387 388 404 412 423 425 428 436 452 475 477
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Паскаль, которая находит все целые числа от 200 до 500, у которых ровно 6 делителей:

```pascal program FindNumbers;

var num, count, divisor: Integer;

begin for num := 200 to 500 do begin count := 0; for divisor := 1 to num do begin if (num mod divisor) = 0 then count := count + 1; if count > 6 then Break; end; if count = 6 then writeln(num); end; end. ```

Эта программа использует два вложенных цикла. Внешний цикл перебирает все числа от 200 до 500. Внутренний цикл проверяет каждое число на делимость с помощью оператора модуля (`mod`). Если число делится нацело на текущий делитель, то увеличиваем счетчик на 1. Если счетчик превышает 6, мы прерываем цикл, так как число имеет больше делителей, чем нужно. Если счетчик равен 6, мы выводим число на экран.

Надеюсь, эта программа поможет вам найти все целые числа от 200 до 500 с ровно 6 делителями! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос