
Напишите программу, которая находит в массиве количество элементов, равных максимальному. Входные
данные Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 . Выходные данные Программа должна вывести два числа, разделив их пробелом: максимальный элемент массива и количество элементов массива, равных максимальному. Примеры входные данные 6 1 2 3 2 3 3 выходные данные 3 3 Помогите,пожалуйста, написать программу в паскале, у что-то не получается

Ответы на вопрос

begin
var n:=ReadInteger();
var a:=ReadArrInteger(n);
var mx:=a.Max;
WriteFormat('{0} {1}',mx,a.Where(x->(x=mx)).Count)
end.
Тестовое решение:
6
1 2 3 2 3 3
3 3
Замечание:
Предложенные в задании входные данные 6 1 2 3 2 3 3 некорректны, поскольку по условию должно быть две входные строки. На этом основании эти данные были разбиты на две строки и соответственно был организован их ввод.



Вот пример программы на языке Паскаль, которая находит количество элементов в массиве, равных максимальному элементу:
```pascal program MaxElementCount;
const MAX_SIZE = 10000;
var arr: array[1..MAX_SIZE] of Integer; N, i, maxElement, count: Integer;
begin // Ввод размера массива Readln(N);
// Ввод элементов массива for i := 1 to N do Read(arr[i]);
// Нахождение максимального элемента maxElement := arr[1]; for i := 2 to N do begin if arr[i] > maxElement then maxElement := arr[i]; end;
// Подсчет количества элементов, равных максимальному count := 0; for i := 1 to N do begin if arr[i] = maxElement then count := count + 1; end;
// Вывод результата Writeln(maxElement, ' ', count); end. ```
Пожалуйста, попробуйте использовать эту программу и дайте мне знать, если у вас возникнут какие-либо вопросы.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili