
Помогите написать программу по информатике (на паскале) на перевод из десятичной системы счисления
в двоичную.

Ответы на вопрос

uses crt;
function detob(x:integer):string;
var s:string;
begin
s:='';
while x>0 do
begin
s:=chr(ord('0')+x mod 2)+s;
x:=x div 2;
end;
detob:=s;
end;
var a: integer;
begin
clrscr;
writeln('Введите число:');
readln(a);
writeln('Полученное число:',detob(a));
readln;
end.



Конечно! Я могу помочь вам написать программу на языке программирования Pascal, которая будет выполнять перевод числа из десятичной системы счисления в двоичную. Вот пример программы:
```pascal program DecimalToBinary;
var decimalNumber, remainder: integer; binaryNumber: string;
begin // Вводим десятичное число writeln('Введите десятичное число: '); readln(decimalNumber);
// Переводим десятичное число в двоичное binaryNumber := ''; while decimalNumber > 0 do begin remainder := decimalNumber mod 2; binaryNumber := IntToStr(remainder) + binaryNumber; decimalNumber := decimalNumber div 2; end;
// Выводим двоичное число writeln('Двоичное число: ', binaryNumber); end. ```
Эта программа принимает входное десятичное число от пользователя и затем выполняет перевод в двоичную систему счисления. Она использует цикл while для получения остатка от деления десятичного числа на 2. Затем остаток добавляется в начало строки двоичного числа. После этого десятичное число делится на 2. Процесс повторяется до тех пор, пока десятичное число не станет равным нулю.
Надеюсь, эта программа поможет вам перевести числа из десятичной системы счисления в двоичную с помощью языка Pascal. Если у вас есть еще вопросы, пожалуйста, дайте мне знать!


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili