Написать программу, которая выводит синусы и косинусы. На языке Си. Заранее спасибо
Ответы на вопрос
#include < iostream > /* Подключаем библиотеку, чтоб работали функции cout, cin */
#include < cmath > /*Подкючаем библиотеку, чтоб работали функции cos, pi */
#define PI 3.14159265 /*Задаем сколько у нас будет значит число ПИ */
using namespace std;
main (){
float a, result; /*Вводим 2 переменные - действительные числа: одно - число градусов угла, второе - полученный результат*/
cout << "Vvedite znachenie ugla" << endl;
cin >> a; /* Вводим значение угла с клавиатуры*/
result = cos (a*PI/180); /*высчитываем значение косинуса, переводя значениезаданного угла в радианы */
cout << "Kosinus "<< a << " raven " << result; /*Выводим полученное на экран */
return 0; /*Возвращает нулевое значение */
}
1) Си-для начала переменные нужно в начало функции объявлять. Если компилятор у тебя си как бы сказать си-шный,тои файл будет тоже си-шный
2)Самым первым аргументом для синуса и косинуса и формула пов(pow)будет вещественное число.
Так,косинус и синус:
cos(Xnumber,4)
У функции синус и косинус только один параметр, а у pow совсем наоборот.
double Xnumber; и другие
I)все переменные нужно объявить , как double.
Читать нужно будет так:
scanf("%lf", &Xnumber);
тебе нужна для пов(pow)?
если да?,то вот:
Пов(pow)pow(cos(Xnumber), 4) + pow(sin(Ynumber), 2) + 1.0 / 4 * pow(sin(2*Xnumber), 2) - 1;
Вроде все,если понял(а),а если нет,то пиши в сообщение,и спрашивай,что не понятно
Для написания программы, которая выводит синусы и косинусы на языке программирования C, мы можем воспользоваться математической библиотекой `math.h`. Вот пример программы:
```c
#include
int main() { double angle; printf("Enter the angle in degrees: "); scanf("%lf", &angle);
double radian = angle * (M_PI / 180.0); double sin_val = sin(radian); double cos_val = cos(radian);
printf("The sine of %lf degrees is %lf\n", angle, sin_val); printf("The cosine of %lf degrees is %lf\n", angle, cos_val);
return 0; } ```
В этой программе мы сначала запрашиваем у пользователя угол в градусах, затем переводим его в радианы (так как функции `sin` и `cos` принимают аргумент в радианах), вычисляем синус и косинус с помощью функций `sin` и `cos` из библиотеки `math.h`, и выводим результаты на экран.
При запуске программы, она запросит угол у пользователя, после чего выведет значения синуса и косинуса для этого угла.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
