Дан одномерный массив из N вещественных элементов.составить программу вычисления их среднего
арифметического,,,,ООООчень нужно на завтра,помогите пожалуйста!!!!Ответы на вопрос
const N={задаём};
var a:array[1..N] of real; sr,summ:real; i:integer;
begin
for i:=1 to N do
read(a[i]);
for i:=1 to N do
summ:=summ+a[i];
sr:=summ/N;
write(sr);
end.
program 1;
uses crt;
cоnst n=10;
var arr:array[1..N] of real;
sum:real;
i:integer;
Begin clrscr;
writeln('Please entel array');
for i:=1 to N do
read(arr);
sum:=0;
for i:=1 to N do
sum:=sum+arr;
writeln();
writeln("result=",sum/N);
readln;
End.
Программа для вычисления среднего арифметического
Для вычисления среднего арифметического вещественных элементов одномерного массива можно воспользоваться следующим примером кода на языке Python:
```python # Создание массива из N вещественных элементов array = [1.5, 2.5, 3.5, 4.5, 5.5] # Пример массива, замените его на свой
# Вычисление среднего арифметического average = sum(array) / len(array)
# Вывод результата print("Среднее арифметическое:", average) ```
В этом примере: - Мы создаем массив из N вещественных элементов. - Затем вычисляем среднее арифметическое, складывая все элементы массива и делая деление на их количество. - Наконец, выводим результат.
Если у вас есть конкретный массив из N вещественных элементов, замените `array` на ваш массив в коде выше.
Надеюсь, это поможет вам с вашей задачей! Если у вас есть еще вопросы или нужна дополнительная помощь, не стесняйтесь спрашивать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
