Вопрос задан 15.02.2019 в 13:12.
Предмет Информатика.
Спрашивает Жупиков Даниил.
Pascal. Составить программу которая позволяет вывести трех значное число, если первая цифра числа
четное,то поменять местами последнию и среднию,иначе поменять первую и среднию. За эту задачу дам 15 баллов.Ответы на вопрос
Отвечает Кутьёнкова Мария.
Var S,a,q:integer;
b,c:real;
begin
readln(S); // вводим трёхзначное число
a:= (S div 100) mod 2; // получаем 1 цифру
if a = 0 then begin // проверяем
b:= S div 10;
b:= b - S div 100 * 10 ; // "вытаскиваем" среднюю цифру
c:= S mod 10; // берём последнюю writeln(S div 100,c,b);
end
else begin
b:= S div 10;
b:= b - S div 100 * 10 ; // повторяем со средней цифрой
c:= S mod 10; // берём последнюю (также повторяем)
writeln(b,S div 100,c);
end;
end.
Наверно можно было и попроще)))))
b,c:real;
begin
readln(S); // вводим трёхзначное число
a:= (S div 100) mod 2; // получаем 1 цифру
if a = 0 then begin // проверяем
b:= S div 10;
b:= b - S div 100 * 10 ; // "вытаскиваем" среднюю цифру
c:= S mod 10; // берём последнюю writeln(S div 100,c,b);
end
else begin
b:= S div 10;
b:= b - S div 100 * 10 ; // повторяем со средней цифрой
c:= S mod 10; // берём последнюю (также повторяем)
writeln(b,S div 100,c);
end;
end.
Наверно можно было и попроще)))))
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Я могу помочь вам с написанием программы на Pascal, которая решает вашу задачу. Вот пример кода, который я сгенерировал:
```pascal program SwapDigits; var n, a, b, c, m: integer; begin writeln('Введите трехзначное число:'); readln(n); a := n div 100; // первая цифра b := (n mod 100) div 10; // вторая цифра c := n mod 10; // третья цифра if a mod 2 = 0 then // если первая цифра четная m := a * 100 + c * 10 + b // меняем местами последнюю и среднюю else // иначе m := b * 100 + a * 10 + c; // меняем местами первую и среднюю writeln('Полученное число:', m); end. ```
Я надеюсь, что это вам поможет. Если у вас есть другие вопросы или пожелания, я буду рад с вами поговорить. Спасибо за использование Bing.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
